cancel
Showing results for 
Search instead for 
Did you mean: 

when i try to open stream vr through oculus home on my pc using air link, PC has a stroke.

TinyGamer16
Level 3

ever since I've moved from the Rift S to the quest 2, I've been trying to connect it to my computer so I can play my PCVR games, and since my cable doesn't work, i decided to use air link, when i start it up it boots into oculus home just fine, but when i try to open steam VR, my PCs screen goes black, my Quest 2 loses connecting, and the cooling fans in my PC crank up to the max, it worked ok before, but now it just doesnt work at all, anyone know why?

4 REPLIES 4

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hello there!

 

We understand that you are experiencing an issue with accessing your SteamVR games from your Quest 2 device while using the Air Link feature to connect your Oculus device to your PC, and this is causing your PC screen to turn black and your Quest 2 to disconnect from the PC. Please keep in mind that Air Link is still an experimental feature, and it may not be able to perform all of the functions that you would be able to do when tethered to a PC using a physical connection like an Oculus Link cable. 

 

Please make sure that your Oculus application and device are both fully updated, as well as your Steam software. Ensure that you have correctly set up your Quest 2 with Air Link by following the instructions listed on this page here. You can also find some information on Air Link's known issues and best practices here on the Oculus website. This information may help you to run the SteamVR applications that you are having an issue with.

 

If you continue to experience an issue with accessing SteamVR games via the Air Link feature, or if you need anything else, please send us a private message or submit a support ticket here, so we can further assist you.

finally got oculus link to work with my cable, and it has the same issue as airlink, im assuming its a graphics driver issue, i have a AMD graphics card.

My two cents,. The following tip helped me , so it may help you.
In case that all checks has been done (driver update, cable etc...) , and all is ok but you still have the black screen with white dots.

 

I suppose also that you have 2 differents GPU (like an onboard GPU for low power activity, and your AMD for high performance)
And you succeed to set the correct GPU for the correct process (like set AMD for process OVRServer_x64.exe)

You may try to go to "device manager" in your windows, then in "display adapters" and try to "disable" your "onboard" display adapter. That will force all process to use your AMD GPU.

 

Then do start your game and occulus link...

If it works, you may try to re-enable your "onboard" GPU .. to test if your oculus link still working 

 

Hope that help

i only have one gpu, and oculus link kinda works now, but its very unstable, will randomly crash my computer when under a heavier work load, never did any of this with my previous headset