cancel
Showing results for 
Search instead for 
Did you mean: 

New Issue Accessing Expansion Files / AVPro video playback

Donald.Dunbar
Level 3

I've had a new issue crop up in the last two weeks across multiple apps with videos failing to play. Previously everything worked fine. This has occurred in different apps after 1. Updating Oculus Integration to 28.0, and 2. Updating minimum Android build level to 23 

 

The facts:

Unity 2019.4.17f1

AVPro Video 1.x

Have READ_EXTERNAL and WRITE_EXTERNAL in the manifest

Calling videos from /sdcard/Android/obb/com.[org].[app]/

Have tried h.264, h.265, both as .mp4 and .mkv; have confirmed with videos I've gotten to play in other apps

 

I've also gone into the app's Permissions in the Quest and though I requested Storage access in the manifest it was set to "Denied". Changed this to no effect.

 

Does this have to do with the Oculus Native Video Player screwing with AVPro? Or is it a new permissions problem?

1 ACCEPTED SOLUTION

Accepted Solutions

Donald.Dunbar
Level 3

Yeah, Renderheads helped me out with it. Here's the thread on their github: https://github.com/RenderHeads/UnityPlugin-AVProVideo/issues/776

View solution in original post

3 REPLIES 3

mofrison
Level 3

Did you manage to solve the problem with video playback?

Donald.Dunbar
Level 3

Yeah, Renderheads helped me out with it. Here's the thread on their github: https://github.com/RenderHeads/UnityPlugin-AVProVideo/issues/776

View solution in original post

Thank you very much, I hope it will help me too!