cancel
Showing results for 
Search instead for 
Did you mean: 

OVRPlayerController not working correctly

Studio_Ile_Pari
Level 4
I'm trying to get the OVRPlayerController (from the Oculus Integration package on the Unity Asset Store) to work. 

I'm building for Quest and I'm using Unity2019.2.0f1 with Oculus Integration v1.39 to build my APK's

I'm able to build and run the APK, but when I push and hold the left hand joystick forward, the avatar jumps ahead a bit then stops.The same happens with the right hand joystick. I have to keep repeatedly releasing then pushing the joystick to move forward. I have played with the OVRPlayerController settings with no luck. 

What am I missing here?

How do I get the controller to move the avatar smoothly with out stopping?

tndvvdsjhg1b.jpg
8 REPLIES 8

Corysia
Level 5
I am having the same issue.  I just upgraded from 2019.1.12f1 to 2019.1.14f1 and upgraded my Oculus Integration package from 1.38 to 1.39.  I am downgrading back to 1.38.

Not only can I not move, I can no longer:
  • Turn with the thumbsticks.  I can't turn at all.
  • Drop LocalAvatar in to the Tracking Space of the camera, I have to now edit the Prefab.
  • Run the HMD Emulator - I get this error whenever I press R.  WASD don't work at all.
    NullReferenceException: Object reference not set to an instance of an object
    OVRSceneSampleController.UpdateRecenterPose () (at Assets/Oculus/VR/Scripts/Util/OVRSceneSampleController.cs:211)
    OVRSceneSampleController.Update () (at Assets/Oculus/VR/Scripts/Util/OVRSceneSampleController.cs:131)

Corysia
Level 5
Downgrading to 1.38 worked.

Studio_Ile_Pari
Level 4
Many thanks to Brian at Oculus for helping with this solution. This is how we fixed it:

First add a "Character Camera Constraint" to the OVRPlayerController Prefab (see image below).

Next delete the AndroidManifest file, then build a new one:
Oculus -> Tools -> Remove AndroidManifest.xml.
Oculus -> Tools -> Generate store-compatible AndroidManifest.xml.

And that's it. This worked like a champ for me. Hope this helps. 🙂


zsas64r421iw.jpg

chilton
Level 3
Where y'all getting 1.38 from? I only see 1.28 on the archives page. 

nirharpaz
Level 3
Corysia
i downgraded
unlike 1.39 the hands appear.
it seems like the oculus wrongly detects the hands as oculus go controller even though it is set to oculus quest.

Studio_Ile_Pari
Level 4
The new Oculus Integration (1.40) is out and it fixes a bunch of these issues.

Corysia
Level 5
I'm trying to get 1.40 working, but the prefabs are a bit different.