cancel
Showing results for 
Search instead for 
Did you mean: 

Quest doesn't appear in Unity's "Run Device" list anymore

jphilipp
Level 4
Hi! I was able to select Quest just fine in Unity's Build Settings - Android - "Run Device" selection while being USB-connected (I have Developer Mode enabled on Quest etc.). Now however, Quest won't show up anymore in that list, even after restarting the PC, the Headset, as well as clicking Refresh on the list or changing to a different USB socket. (The USB connection itself works, as I can see the battery status change when plugging in.) What can I do? Thanks!
- Anyland dev -
5 REPLIES 5

Geist2501
Level 3
The battery status only means it gets power, not that data is being transmitted - just saying.

Does it appear as Quest in your explorer? You could try reinstalling the Drivers i guess.
Are you sure you have given permission to your pc to establish a debug connection?

Jattier
Level 4
As long as you can still deploy to the default device, it shouldn't matter that the exact device ID doesn't show up in the dropdown.

wearablecompute
Level 2
first check if adb can see it using "adb devices" command. if you don't have adb you will need to download it, it's small and standalone. if this can see it then it's a problem with unity, if it can't then there is a problem with the connection. I have noticed that PC-USB ports don't charge the quest up enough so try plugging it into the wall for half an hour.

jull360
Level 2
Plug Quest, Put headset on, authorize PC if popup appears

ROBYER1
Level 4
Check if your developer mode is on, mine disabled its developer mode after the latest update today