cancel
Showing results for 
Search instead for 
Did you mean: 

Bug? All My Art Disappeared

kristianolson
Level 2
In several of my Quill files, all of the layers show up with nothing on them. I'm afraid to keep working with this program if that is going to happen again. Attaching one here so hopefully someone can take a look.

This was done on a brand new Alienware PC that I specifically bought for Oculus and Quil last week.

Thanks,

Kristian
1 ACCEPTED SOLUTION

Accepted Solutions

chorne
Level 5
Hey Kristian - sorry for the problems!
I hopped into your quill.json file in a text editor and noticed the root transform had:
"Transform": [inf, -inf, inf,0.727409,............"

Those infs are.....weird. I replaced them to look like 
"Transform": [1, 0, 0,0.727409,............"

and it loaded up just fine. My guess is that you're scaled way up or way down while saving, and we're writing out these funky values. We'll look into reproducing it and fixing it on our end. It may be a while until we can kick out a patch for this issue though.

I noticed that the Root node was selected. I'm guessing you have been using this to transform around the scene? This might be what's triggering the bug. I've attached an image that better shows what I'm talking about.

5vh86y326t77.jpg

To "deselect" the arrows icon you just click them a second time. You can still move around the scene in this mode - but it keeps us from saving out a ton of crazy values into your quill file. Hopefully that makes sense? Let me know if it doesn't (and if that fixes your other files as well).

View solution in original post

8 REPLIES 8

chorne
Level 5
Hey Kristian - sorry for the problems!
I hopped into your quill.json file in a text editor and noticed the root transform had:
"Transform": [inf, -inf, inf,0.727409,............"

Those infs are.....weird. I replaced them to look like 
"Transform": [1, 0, 0,0.727409,............"

and it loaded up just fine. My guess is that you're scaled way up or way down while saving, and we're writing out these funky values. We'll look into reproducing it and fixing it on our end. It may be a while until we can kick out a patch for this issue though.

I noticed that the Root node was selected. I'm guessing you have been using this to transform around the scene? This might be what's triggering the bug. I've attached an image that better shows what I'm talking about.

5vh86y326t77.jpg

To "deselect" the arrows icon you just click them a second time. You can still move around the scene in this mode - but it keeps us from saving out a ton of crazy values into your quill file. Hopefully that makes sense? Let me know if it doesn't (and if that fixes your other files as well).

chorne
Level 5
Also I've attached a fixed version of your quill file to this message. 

kristianolson
Level 2
Thank you! Everything is back to normal.

murascotti
Level 3
@chorne  I think I'm having a similar issue.  I loaded up my project in Quill, did some work in it, quit the app, came back, and all the layers are there but I can't find or see any of them in the scene.  Mind if you take a look at my .json files and see what could be causing the hitch?  I'm running up against a deadline, so any advice you could give would be appreciated!

joan
Level 4
@murascotti: Try this one.



alecz
Level 3
Hi. I believe it's my turn to experience this. What to do to avoid it?
I don't recall playing with the Select icon / node root in the layer menu. 

I saved my file last night, wanted to continue this morning but when I load the project all I can see is the background even tho my layer is there ... lost somewhere in cyberspace! Please let me know for any advice!




alecz
Level 3
Oh, I opened the json file and looked at the "Transform" command line but didnt find any 'inf' 

schevrel
Level 4
This is due the layer being scaled very high which turns it invisible. Quill has a scale culling mechanism to make things that are too small or too far away disappear. In your case, it's too far away due to scaling.

Please do the following: in the transform tool panel, make sure auto select transform object is turned off, then in the layers panel select your guilio layer for moving (click on the 4 directional arrows for that layer until it is solid black) then, hold down the grab/transform trigger and the joystick down at the same time until your scene comes back into view.