cancel
Showing results for 
Search instead for 
Did you mean: 

Actual FIX for "Can't Reach Oculus Service".

NSA205
Level 2

First of all, i have that problem since the two last updates. I searched the net for all sorts of fixes.

And got f*** pissed every time after about 3 hours of nothing.

 

DELETE "C:\Program Files\Oculus\Support\oculus-runtime\server-plugins\RemoteHeadset.dll".

 

Thats not a joke.

I hope that it will work for others too.

 

Mfg. Chroohn.

9 REPLIES 9

Cadavering
Level 2

dude u are the best. holy sht thank you

RayanVr_FR
Level 2

BRO i don't believe it was so simple thank u so much

Uprank
Level 2

Did this, broke my entire oculus app forcing me to reinstall it. 😑 be careful doing this!

HaZeOC
Level 2

Oh my god bro thank you so freaking much, i had this problem for like a week now and i did everything and every fix i saw on yt and nothing worked, until i deleted this one file XD, but yh thank you very much bro u just saved me.

nuryzu
Level 2

it works but my headset wont connect

Hi nuryzu! We understand your headset is having trouble connecting, but we're here to get you back into gaming! Something you can try is to see if an unmodified Oculus PC app install will connect to your headset. To accomplish this, repair the app by following THESE instructions.

If that doesn't work, please tell us what model headset you're using so we can provide tailored troubleshooting. Thanks!

i already repaired 5 times. i have a quest 2. few months ago everything worked but now it wont

Thanks for getting back with us! Let's look into getting Link up and running for you again. Here are some things you can do:

  • Ensure your graphics card drivers are up to date.
  • Ensure your Oculus drivers are up to date.
    1. Close the Oculus app.
    2. Press the Windows key + R on your keyboard to open the Run command.
    3. Enter C:\Program Files\Oculus\Support\oculus-drivers.
    4. Open oculus-driver.
    5. Open the Oculus app and then try to connect your headset again.
  • Confirm your USB power settings.
    • Open Device Manager.
    • Locate your USB ports - Expand the universal serial bus controller section at the bottom of the list. Look for the "USB 3.0/3.1/3.10 eXtensible" items.
    • Right click and select Properties.
    • Navigate to Power Management.
    • Ensure that the options to save power are deselected.
      • Not all of these listings will have these Power Management options, so we can skip and move onto the next item in the list until completed.
  • Check for Selective Suspending.
    • Right-click Start
    • Click Power Options
    • Click Additional Power Settings
    • Click Change plan settings
    • Click Change Advanced Power Settings
    • Find USB Settings
    • Make sure that Selective Suspend Setting is set to Disabled, and not Enabled

If these steps do not work, please collect logs by following THESE instructions, then submit the resulting ZIP file in an email support ticket HERE, so we can look deeper into your PC and ensure that it's compatible and that nothing else is preventing you from using Link. Thanks!

al3xp2p
Level 2

OMG THANK YOU SO MUCH, I WASTED SO MUCH TIME WORKING AROUND THIS, THANK YOU.