cancel
Showing results for 
Search instead for 
Did you mean: 

All Problems for Oculus Rift S

auxiliaryxx
Level 3
Use this discussion for all problems related to the Oculus Rift S! I have found most solutions for mine which I will be sharing on here as well.
Common Problems: Tracking, Guardian, Setup, Freezing, Snow Pixels, Jittering, Plug Problems, USB 3.0 errors, Game glitches, Camera problems, Headphone static, Some games don't run, Oculus home freezes, Steam vr wants to setup, Speakers make noise, Ipd glitching on horizonal side, fov is small, no sweetspot.

I will tell you how to improve FOV, TRACKING, SWEETSPOT AND PERFORMANCE as best as I can.

Let's get started!
142 REPLIES 142

MAC_MAN86
Level 9
It can work 1st time but once the head sensor sleeps it struggles to awake so there's your black screen. The suggested solutions are posted above. BTW whenever plugging in RIFT S USB, wait just 5-10secs (not 5mins) then plugin DP.
USB must be 3.0 so it is either your Mouse/keyb OR front USB OR add a USB3.0 PCIe Card NOT 3.1 as it may add noise interference.

If you already Updated to WIN10 1903 then it is a lottery if it works and if not needs the above HOTFIX cab installed.

If on 1809 In Win10 Pro you can select Advanced Options>Semi-Annual Channel drop down plus 365days. This can be changed back once any fix is Official.
In Win10 Home you can set 2nd Option for Metered Connections which also loses track of the live tiles in Start Menu. It can be set back anytime.
Come to think about it, a fresh OS of any may still require us to do USB Updates in Devices as these aren't picked up as their manufacture due to a Microsoft Default being used firstly. However, that could be the issue if then using the ASMedia Drivers. So is why a fresh OS works but not manually updating USB in Drivers to any ASMedia.

OR you may just update the USB 3.1 HUB Driver to xHCI which is less performance by a Manual Selection.

Cool_MC_Cool
Level 4
NEW driver from nvidia for official support - would be better before launch xD

TomCgcmfc
Level 16


NEW driver from nvidia for official support - would be better before launch xD


I just updated to this (430.86) and it did not fix or improve any of my Rift S issues like controller lag and screen flashing.
9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, Corsair 750w, Quest 1 w/Link and wireless w/VD, Vive Pro.

zorex
Level 2
I have a problem with one touch controller of the rift s... The vibration of the right controller i can barely feel it, is not working properly... I have to get a replacement of the controllers and the headsed too? The headset is working fine...

bgast7851
Level 2
10. ENJOY! and avoid using Oculus's shitty buggy software, stick with steam vr
I have had nothing but trouble with my oculus rift s. I am about ready to return it for a refund. I bought it through Amazon. What is so special about Steam VR? The thing is I have bought all of my games through Oculus and really hate rebuying on Steam. The game that I am playing the most is Defense Grid 2 but I can't get it to display correctly at all. I get these black edges (I'm guessing these are tracking issues) both seated and standing. I am not a good gamer at all and even navigating the rift is a challenge for me, but I love the VR.  Is there a solution besides buying the games all over again in Steam?

MAC_MAN86
Level 9
SteamVR is installed to 2nd Drive? Mine is and so too is Oculus Home to avoid the past Windows Permission issues forced on us via Win Updates. They constantly break connectivity for odd things eventually due to using the OS Folder C:\Program Files.

Porcochino
Level 2
Had tons of troubbles with my oculus rift s. The first day all worked well. Then in second day the headset didnt worked cause of blackscreen bug. Fixed it by using beta updates and played a little bit. Today, third day, i plug in my Display Port, it connects and two seconds after loses connection and says that is unplugged. Camera dont show up on Device Administrator. What can i do? 

Tumyue
Level 3
My controllers dance around me, i has try to reinstall windows from 0 and format the ssd where i have games and nothing the issue continue, it gone good 1 min then start to dancing around me.

jermzii
Level 2
Mine worked perfect upon first connection. I Had to allow camera permission. I did the intro and even played Blade and Sorcery and The Lab. Now it says my USB 3.0 is not compatible. And will no longer connect.

Ethrelaed
Level 3
And here a old issue from a newcomer with a new product: Do not, and i repeat in caps: DO NOT EVER DARE TO USE THE RIFT S WITH GLASSES! Do not listen to people that are saying glasses and rift s are fine. Scratches in my Rift S and my glasses tell another story. And you will only find out about the issue as a newcomer when it is to late BECAUSE THERE IS NOWHERE A CLEAR WARNING.