cancel
Showing results for 
Search instead for 
Did you mean: 

Beat Saber Stutter whenever crossing sabers? Rift S

stateofstatic
Level 4
Weird problem...I just got a Rift S for my wife, and whenever I'm in Beat Saber I get a stutter when the sabers touch.  At first I thought it was a fluke, but then I pulled up the Oculus Debug Tool and looked at the Performance HUD in App Render Timing Mode.  Under "App GPU Time (ms)" when the sabers are not touching, it's 2-3ms, but the moment they touch together and the controllers vibrate it spikes to 20-25ms...if I cross them back and forth rapidly its just non-stop spikes and a stuttering mess.

Her system is a Ryzen 3600x, GTX 1080, MSI X470 board, Win10 64 pro, m.2 sata drive, 16gb ddr4 3200.  Things I've tried so far is to disable all other USB ports (even unplugging mouse and keyboard), physically remove USB cables from motherboard to front case USB ports, make sure USB power saving is disabled, use display driver uninstaller to remove NVIDIA drivers and reinstall clean, uninstall reinstall chipset drivers, uninstall reinstall oculus software, disable CPU c-states, force P0 state on the GPU, move the GPU to another PCI-E slot, remove PCI-E wifi card, enable/disable MSI for devices individually and collectively, disabled onboard realtek audio controller, disabled internal NIC, power plan set to Ryzen High Performance, NVIDIA power management mode set to "prefer maximum performance", Virtual Reality Pre-Rendered Frames tested from a setting of 1-4, Low Latency Mode tested from Off-Ultra, no anti-aliasing, lowest graphics options, render super sampling turned down to 0.7...issue still persists with no improvement or reduction of the App GPU time spikes to 20-25ms.

I also attempted to reproduce the issue on my own PC (Ryzen 3700x, GTX 1080i, Gigabyte X570, Win10 64 pro, m.2 sata, 16gb dddr4 3200) but it works flawlessly...no stutter or GPU frametime jumps crossing sabers or otherwise except for when going from a menu to menu, or menu to actual song launch...2-3ms solid all the time. 

Scratching my head as to what is causing this...any help would be appreciated!


3 REPLIES 3

stateofstatic
Level 4
Forgot to mention I tried both the standard oculus software version and the beta...also increased application priority of OVRServer_x64 and beatsaber.exe to high, still the same issue.  This is for beat saber purchased from the oculus store directly btw, not via Steam through SteamVR

Conk45
Level 2

Hey mate, did you ever find a solution to this? I'm having the exact same issue and I can't see it referenced anywhere else.

 

 

kasper.knudsen
Level 2

I have the same problem. Took a break from the game for a few months, and came back to this.
It makes expert+ maps unplayable. I hope we get an answer.