Showing results for 
Search instead for 
Did you mean: 

Brand new Rift S sensor check issues

Level 2
My Rift S I purchased for black friday arrived a few hours ago and I have been having some seriously frustrating problems. 

First of all the oculus app it self is acting very weird with the majority of the time I just get stuck on the loading screen watching the circle endlessly load. The setup is a whole different story. I don't know if theres anything wrong with my USB or HDMI ports but it took the oculus software literally 10 whole minutes just to recognize that I had plugged them in for the first time. The sensor part of the setup is where I found myself at a dead end. The sensor check has been running for approximately 40 minutes now and its still trying to "check sensors". I've searched for hours upon hours already looking through threads with people discussing their sensor issues and have found no solution that has worked for me. At this point im starting to question whether or not my Rift S is faulty.

I already enabled camera access for windows and completely reinstalled a fresh copy of the software multiple times... 

If anyone has any solutions or ideas PLEASE leave them down below.

Level 15
I am a little confused, Rift S does not use HDMI nor does it have sensors.
Rift CV1| Rift S| Quest| Reverb G2| Index| Vive Pro 2

Level 2
Oh yeah I meant DisplayPort. I don't know if I should be seeing anything on the headset while its connected but theres nothing, just total darkness and I cant get passed the Sensor check step in the setup

Level 3
I had the same issues... I tried everything that I found on internet, what I did was to reinstall the drivers for the usb for all the ports, unplug the cables and plugged again... It was working fine for 2 days, byt now it disconnects every time I restart the PC

Level 3
so I found this and solved for now
Ok, I just fixed mine. Hopefully this can help some of you too. I had to go into device manager, and change the driver for the ASMedia USB3.1 eXtensible Host Controller. For some reason, even though that controller works fine for other USB 3.0 hardware, it causes problems for the Rift S.

Right click it, choose "update driver", then choose "browse my computer for driver software". Choose "let me pick from a list..". Untick "show compatible hardware", choose "(standard USB Host Controller) from the menu on the left and select "USB xHCI Compliant Host Controller" from the box on the right.

This will replace the ASMedia USB driver with a generic USB3.0 driver from Microsoft. As soon as I did this, the Oculus Rift S sensor check worked fine, and I could use the Rift S without and dramas.