cancel
Showing results for 
Search instead for 
Did you mean: 

Display Port not working, pls help

loffry
Level 2
so, i buyed the oculus rift s for christmas, when it arrived it worked fine, until now, i launched the oculus software, started a game, the game worked fine except for the problem that the rift s wasn't showing up anything on the screen, the controllers weren't responding to any button (still connected btw), so i decided to re-do the configuration, so now the software can't find/recognize the display port, even tho it's connected to the graphic card, i tryied changing the port but still nothing, anyone got the same problem? if so, pls respond

edit: tried reeboting again the pc and now it the displayport shows up, but when i continue the configuration i still can't see on the rift
5 REPLIES 5

Xenohort
Level 2
disconnect the dp connector from the headset and give it a go again if you look on the oculus app it will say weather the dp is good it will show usb and dp with green dots if that doesn't work most likely its your cable but first restart computer with cable disconnected  then pug usb wait a couple seconds thenn plug in your displayport connector look in app see if both are green also you can try updating all drivers for video card and maybe usb another thing i had an issue iwth on one of my computers was a setting in bios for usb just take a look cant hurt

loffry
Level 2
thx i'll try

hansknapp1
Level 2

FIXED IT! (by myself) after hours of trying things, i FINALLY made this headset work !!

BUT make sure your GPU also has a 1.4 DP connection (my 660 did not had it, now my 1060 has)

 

Created a small youtube recording (Less then 3 minutes)

https://youtu.be/YNLIRCCAOo4

 

I have tried so many things, even for an IT Support Engineer. Been though hell, and i'm not saying Oculus Support did not help, but all steps where obsolete. (been problem solving more then 20 days with Oculus Support) This is the ONLY working step i could not find anywhere online, even support was not updated by this! 

 

Let me know if this also fixed your problem 🙂 

trying this resolved the issue of the displayport cable not getting detected, but i still got the issue of the headset, when i wear it the display does not show up anything, and idk why another kinda issue showed up, when i was doing the configuration the controllers were not getting detected by the software, even tho they worked fine

oh- and i've seen you've been searching fot IT support, so i guess you're italian? if you are then you could respond in italian so that i can even understand better🙂