cancel
Showing results for 
Search instead for 
Did you mean: 

Display port not connecting

Rifter87
Level 2
Been getting this for long time now.
Tried : Uninstalling  software/reinstall,
Tried different pcs,
Reseating cables,
Restarting drivers
Please help!
4 REPLIES 4

TK_Prince
Level 4
Just pray. This is a software issue. It's exist since march and Oculus don't fix it and don't communicate on it. We are lot of to have this bug. There is nothing to do. Sometimes when you repair the Oculus app then plug in / un plug in / plug in etc headset rework, sometime not ...

dan_m_griffiths
Level 3
Yes. Search the forums and you'll see that there are many in the same situation. I had to send my headset back after completing all their troubleshooting.  That was in May.  I'm still waiting, with no date when I will receive a replacement.  

CallsignPanzer
Level 2
I just got this today for my birthday.  After 3 hours of troubleshooting and reading all of the forums, I still cannot get it recognize the display port (with the Oculus adapter) so I can finish the set up.  Any new ideas?  The last day I can return the Rift-S to Best Buy is tomorrow, but I'd like to keep it, if I can get it to work.

I have a Republic of Games, Asus LAPTOP-G29ET1T9 gaming laptop.  I have verified it meets Oculus' minimum system requirements and everything is up to date.6cot6akt2q25.pngzcug5rndtuyk.pngv3swdco7a6io.png

dan_m_griffiths
Level 3
A lot of people are having the same problem. It was to do with the last software update. I am still waiting for a replacement.  Honestly, I don't see them solving this any time soon. I'd get your money back from the store.