cancel
Showing results for 
Search instead for 
Did you mean: 

Display port not recognized now... :( Rift S

Clarkbruce
Level 2

Hey all. Unfortunately I went to plug into my Rift S today. Its been about 4 months or so since I've used it and the USB connects but the display port isn't recognized. I finally was able to get the display green check on setup.. then the sensors were in an infinite loop and wouldn't recognize. Then I would go back and then the green check is gone again...

 

I did all troubleshoots that I've found. (Enable camera access, plug in order, uninstall oculus app and reinstall, update nvidia drivers, USB drivers updated, USB power enabled). Spent the last 3 hours trying to fix this....

 

I have NEVER had an issue with my Oculus and its always worked flawless. I even have a stand so it's not as if its mishandled by any means.. 

 

Oculus doesn't look like they even sell the cord anymore. It's currently unavailable and I don't want to buy another for 180$ of amazon...

 

Any recommendations?

 

I have a custom built Nvidia 3080 RTX FE, AMD 3700x, 16gig ram, 850PSU

5 REPLIES 5

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hey there Clarkbruce! We appreciate all the troubleshooting you've done so far. We'd love to look into this with you so please click HERE to contact us by email or chat. Thanks!

SupremeAnubis
Level 2

Ok so if you just recently got the new nvidia GEFORCE update, revert it back to the previous version. Same thing happened to me and USB wouldent connect. After I reverted the NVIDIA update, it started working again.  I reverted using this link : https://www.nvidia.com/en-us/geforce/drivers/

Clarkbruce
Level 2

I'm trying this right now will update you!

So it tried and unfortunately it didn't work... I reverted back to august when I know for a fact my oculus was working.. and it still doing the usb working and then the display isn't.. Idk what else to do.. Customer support wants me to hook my oculus rift S to a friends computer but i don't have anyone close that I can do that with.. So I'm pretty stuck. 

@Clarkbruce - Even if you do plug it into someone else's computer, if its broken FB will do nothing, they don't sell the cable or any spare parts anymore. They are just putting barriers in your way so you give up trying to get support, and think its your own fault, when its their fault. You wont get anything out of these people, they just want you to move to the Quest II - that way you are more in heir eco system, and not able to ignore it and just run steam etc