Showing results for 
Search instead for 
Did you mean: 

Displayport issues on Brand New Rift S

Level 2
What appears to be a common issue from what I've googled, but my displayport cable is not being recognized in my Oculus App.


Things I've tried:
-Unplugged and replugged USB and displayport
-Update Graphics, Bios, USB drivers
-Turn off power management in USB Device section
-Tried different display ports and USB 3 ports.
-Reverted Graphics drivers to drivers from 3 months ago (saw it worked somewhere for someone)
-Unplug all other USB devices, minus keyboard and mouse
-Changed my preferred plan under Power Options
-Reseated the cable on the headset itself

Is there anything I could be missing for troubleshooting? Is it a bust cable?

Level 7
Desktop? Laptop? Computer spec? More info is needed

Level 2

Desktop? Laptop? Computer spec? More info is needed

Right, desktop
CPU Ryzen 7 3700x
MOBO ASUS TUF Gaming x570-plus
GPU EVGA 980ti

I eventually got a powered usb hub and plugged it into that. It worked for about halfway through guardian set-up then went to black screen. Now to try it out again I try the different USB and DP, even not using the powered USB hub sometimes. And I'm getting mixed results. Sometimes I can get the headset working for about halfway through guardian setup and the other times its just a black screen. The controllers are responsive though if I press the home button, and if I try to launch a game on steam, I can see the mirror on the monitor with the headset tracking its movement, just no visual on the headset screen