cancel
Showing results for 
Search instead for 
Did you mean: 

Enrolled into the v.18 PTC and No Displayport Connection on my Oculus Rift S

nailedzzz
Level 2
I was having problems with "USB connection not working" for 4 days and just now only found out that there was a new PTC version. Tried that out and now it say that my new problem is No displayport connection. I had my Rift S for 4 months and it worked like a charm until 4 days ago.
6 REPLIES 6

dan_m_griffiths
Level 3
I feel your pain. Had mine since the 13 May. Worked fine for two days. Now I have the 'connect your display cable' problem.  Usb 3.0 connects fine with green light.  Display port connects for 3-5 seconds with a green light then goes back to the searching circle.  Tried all the trouble shooting still waiting for Oculus to get back to me on my ticket.  Just a bad joke this software.

nailedzzz
Level 2


I feel your pain. Had mine since the 13 May. Worked fine for two days. Now I have the 'connect your display cable' problem.  Usb 3.0 connects fine with green light.  Display port connects for 3-5 seconds with a green light then goes back to the searching circle.  Tried all the trouble shooting still waiting for Oculus to get back to me on my ticket.  Just a bad joke this software.


Yep, im having the same problem with you on the displayport now after support told me to download the windows update assistant. This software sucks. There has been no update dedicated to the Rift S this month if im not wrong.

dan_m_griffiths
Level 3
I bought a PCI-e card that connects to the power supply. I'm going to try that tomorrow and I'll let you know how I get on. Apparently it is a USB problem and not a display port problem, even though that is what the software reports.  I do not hold out much hope.

Honosuseri
Level 4


I bought a PCI-e card that connects to the power supply. I'm going to try that tomorrow and I'll let you know how I get on. Apparently it is a USB problem and not a display port problem, even though that is what the software reports.  I do not hold out much hope.


Yes the logs state a USB connection issue before the DP, FYI I'm in the same boat as you.

I've been using the Rift S for a good 7 months, plugged directly into my Motherboard. I know the Etron controller is not true USB 3 so I disabled it but the intel chipset USB3 ports are fine. I've never needed a powered USB hub although people keep recommending it. I play VR seated, the Rift S cable has no kinks or obvious damage.

Having reinstalled the software. I can't even opt back into the public test channel now the software just force closes, opens and closes in a loop. The "stable" Oculus App keeps giving me the "no Displayport connection" error. I wish you luck with your potential fix but like you I don't hold much hope for it. I either have a faulty HMD or it's a software issue from what I can deduce from my troubleshooting.

TK_Prince
Level 4


I bought a PCI-e card that connects to the power supply. I'm going to try that tomorrow and I'll let you know how I get on. Apparently it is a USB problem and not a display port problem, even though that is what the software reports.  I do not hold out much hope.


Please give us info if that worked for you. Personnaly I hag an Rift since 5 years. NEVER NEVER had a single problem. I get a Rift S since near one year. And never had problem with it ... And now, since MARCH, it doesn't work anymore ...

Erkkipenapetter
Level 3

TK.Prince said:



I bought a PCI-e card that connects to the power supply. I'm going to try that tomorrow and I'll let you know how I get on. Apparently it is a USB problem and not a display port problem, even though that is what the software reports.  I do not hold out much hope.


Please give us info if that worked for you. Personnaly I hag an Rift since 5 years. NEVER NEVER had a single problem. I get a Rift S since near one year. And never had problem with it ... And now, since MARCH, it doesn't work anymore ...


Similar story here, CV1 worked well enough up until March. The software update (v15?) in March broke everything. Then some version of v16 worked ok, and now again v17/v18 broken the same way as before. Fun times. 🙂 It's now been over a month total of not being able to do anything with the Rift.