cancel
Showing results for 
Search instead for 
Did you mean: 

Main Oculus application fail to download

NerdyTalk
Level 2
Dear Oculus.

It's me, Austin!

It all started last night when I couldn't get my copies of Elite: Dangerous and Boneworks to download off the oculus library. It would get about halfway through the download and hang, giving me an error to check my internet connection, which was weird, since I was streaming YouTube the entire time with no issues, and have at least 15mb/s download speeds, so I shut everything else down, and tried again. Same results. I tried restarting, shutting down, hard restarting, and hard shutdown, no avail. I started looking for help in forums, was directed to disable antivirus programs, I went a step further and disabled my antivirus and firewall entirely. With my PC fully open to the internet, I tried again, and got exactly nothing. so I uninstalled Oculus from my PC.

BIG MISTAKE.

Now I cant even reinstall oculus, it hangs at small download amounts like 189 MB, 136 MB, and 128 MB. those are the most common numbers. Another forum noted to delete the main drive oculus setup download cache. That had mixed results. I could download larger portions of the app, but it still hung before getting halfway. (no antivirus, no firewall, I'm over here raw-dogging the internet at this point) another forum says to restart the install app over and over, deleting the cache each time and restarting the PC, but that got me nowhere after 10 or so tries. a final forum tells me to reset my modem or use a VPN, as they think that it has something to do with my IP address getting stuck in the server. That ALMOST works, now I get my downloads to about 5 out of 5.12 GB, but it still hangs, and it takes about 20 minutes each time I try it, which if I recall correctly is 6 attempts at this point. (all the while I have no protection on based on Oculus's recommendations)

Keep in mind that the forum posts where I'm getting my info go back to 2016. 

2016.

This has been an issue for oculus for half a decade. almost since its inception. what are you doing over here? You have the backing of one of the largest tech companies in the world, and I cant play on my system because you haven't fixed a bug that's been around since Harambe was murdered!

What needs to happen for me to get the oculus application back up and running so I can play my purchased games? 

(I swear to you, if someone from Oculus support asks me if I have tried turning it on and off again, I'm gonna sell my Oculus for half price and get the Index.)
0 REPLIES 0