Showing results for 
Search instead for 
Did you mean: 

Oculus Rift S Black screen

Level 2

New Oculus Rift S, arrived today, the tutorial worked after the setup.

After a while I downloaded more games and put the oculus aside.

After few hours when I tried to play again nothing worked, I couldn't see anything, the sound did worked.


Tried reinstalling the Oculus app, unplug and replug  the cables, updated windows and graphic drivers.


It's really sucks for first experience like this on the first day.


Windows 10 Pro 20H2

GTX 1070Ti

Intel i7-8700K


Level 7

Have you tried disabling your USB port power management options?

You want that turned off.

I see you said you tried unplugging/re-plugging, but have you used different ports?

And fully rebooted from cold, not just a restart?


Leeds, UK.

Intel Core i7 7700K 3.7GHz | RAM 32GB DDR4 2666MHz | GeForce GTX 1080 8GB |

"Behind every mask there is a face, and behind that a story...."

I got it fixed eventually yesterday by changing the DP port.

But today I had to unplug the USB and plug it again in order to use the Oculus.

I'll check it next time (I've disabled the USB power management)