cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Rift S - Failed to Install or Froze

Hastie5
Level 2
I just got the Oculus Rift S and I went to install the program onto my computer and it either asks me to restart my computer, or it freezes at about 45%.  I have tried disabling windows firewall and any third party protection, create a new user as admin, delete everything and try again.  Even went through all of these forums and nothing as worked.  Does anyone have any knowledge or possible solutions?  

It freezes on "oculus-dash has 2063 outstanding chunks."
2 REPLIES 2

Hastie5
Level 2
***UPDATE*** Everything is working!  Thank you Geek Squad!

For anyone ever having trouble with downloading, if you uninstall anti-virus and turn off Windows Defender, double check to make sure there are no other programs whatsoever running.  They found a program called Acronis that I have never used before that was running anti-virus software that was the cause.

Winning_Glory
Level 2
I also just got my Rift S and accidently went to minimize the setup tab but exited out of it. It will not let me redownload the setup either.