Showing results for 
Search instead for 
Did you mean: 

Oculus Rift S - Video will not stay on

Level 2
The last thing I was doing was playing in the virtual theater Bigscreen Beta app last night. All of a sudden my headset crashed for the first time after almost using it for a year. Had no problem playing on both Steam and the Oculus app.

I tried to restart it and I would get the "no audio for headset" notification on my computer screen. It turns on and the screen came on for only a few seconds into the grid room and then blacks out before going into the Oculus home room.

When it blacks out it makes this tttzzzzzzzzz crackling sound. I've tried different usb ports on the back of my computer and I've just tried a different displayport connection on my GPU. That did not resolve the issue either.

Is my headset now dead or faulty at this point? I can only boot it up for a few seconds before blacking out with that buzzing sound.

Now with the cable still plugged in and my headset is not on my head. I can see a white light and the Rift S in my playback devices where the volume control is. Speaker in my Rift S still works fine. Now after trying to put on my headset, I get a set up guardian notification with my Rift camera turned on. As soon as I pick up my controllers to reset my guardian, I get teleported back into the grid room and everything else started to lag and stutter again. The grid room is also getting the 3 dots icon.

What is going on with my Rift!???

Yes I did an update with my Windows 10 OS. It is now up to date.

Level 2
While any you guys aren't any help at all to me. I fixed it without any of your help.

So the solution was that I just needed to fix the driver in Device Manager and change it from the search by list option and not the browse the web for a driver option. From there I selected the other driver that is unselected and clicked on that one and installed the same thing on my other Oculus driver and restarted my PC.

After restarting my PC, I put on my headset and everything was back to normal. I went ahead to set up my gaurdian system. No problem there. Tested out a game for a few minutes on Beat Saber. No problem there.

It turns out it was a driver issue in my case. Dumb Oculus Support couldn't even figured that one out. A simple YouTube search provided a bunch of solutions depending on your scenario and what you can do to fix your headset.