Showing results for 
Search instead for 
Did you mean: 

Oculus rift s headset graphics go black after 40 seconds of me putting it on.

Level 2
I've had my oculus rift s for about a month now and only used it about 4 times with absolutely no problems up until today. I just recently moved to a new place and now the graphics in the headset wont stay on for more than 40 seconds or so. I unplug the display port and plug it back in and 40 seconds later it turns off again. I've checked everything I've done everything I've seen on the internet to try and fix it but nothing has worked. I just want to play my games. This hasnt happened before. Can anyone help? Customer service couldn't. I still hear the audio. I see the sensors and controllers are working through my monitor and the graphics through my monitor and it shows when the headset is looking around but theres no graphics in the headset itself. It just turns black. I just want go use my vr!!

Community Manager
Community Manager
Hey @Zen741 from the logs in your ticket, adjusting the Nvidia settings so that your display on your laptop is ran from the Nvidia graphic chip rather than the Intel one, may influence the issue. Also ensuring it's plugged in and the power settings within Windows are set to high performance. Update your ticket with the results so that those steps are noted as done and aren't repeated later.

Level 2
I tried updating the power settings for the usb and everything still doesnt work. And it's not the cables either and the ports work perfectly fine

Level 2

I had the same problem and I have solved it. I have a Rift S working about 1 year ago and suddenly this problem came up a few weeks ago.

I have tried:
-Reinstall NVidia graphics drivers
-Reinstall Oculus
-Other USB ports
-Reconnect the HMD connector

Nothing has worked, so I thought about reverting the NVidia drivers, installing an old version. It's the solution.

I have an RTX 2060 and downloaded the drivers from two months ago:

Just download the driver for your graphics card, from about two months ago and it works! Even without restarting PC.

Level 2
Nah I'm not reverting. It was a problem with the headset. I put up to a test kit that's supposed to turn blue if the headset is working. It turned yellow. I got a refund and a new rift s is on the way