Showing results for 
Search instead for 
Did you mean: 

Oculus rift s headset sensor check fail

Level 3

Hello guys, I'm having a bit of trouble with my oculus rift s, the problem being that the usb and the displayport both read normally but once i get to the next stage of the set up it tells me that the sensor check has failed, despite the oculus rift itself and its cables work fine (i tried it at a friends other pc and it works fine and dandy) im not very good with computers but i tried every single method i could possibly find, switching usb ports, the waiting time, displayport on the integrated graphics card and non integrated ports. I disconnected other accessories that use sub ports, i updated the drivers, did prioritize the electricity going into an specific usb, obviously i made sure the cables were connected to the usb 3.0 but i also tried connecting it to a regular port just in case. restarting the pc. updating the pc. updating the graphics card. honestly i can't think of anything else, if anyone is able to give any information about what to do that'd be greatly appreciated. 


Level 5

wich software version of oculus are you running? and what chipseta had your usb 3 ports?

the firmware is at 2.2.0 and the chipset is a intel 200 series chipset family PCI express root port #21 - A2EB

Try solutions I've posted here:


Some intel chipset are blacklisted now.

Level 3

That's the exact issue I was having. I spent 6 days trying to fix it while waiting for Oculus to reply to my ticket.

I tried everything I could find on the internet going back a few years through forums, youtube videos, reddit etc.

Oculus eventually asked me to send my headset and cable in for RMA.

I did that on the 12th Feb.

Still haven't had my headset back as of today 7th March.

I'd open a ticket now if I was you to get the ball rolling.

My headset worked fine 4th Feb but on the 5th Feb I had the exact issue you describe. 

Either an Oculus or Windows update has bricked something.

follow the step on the linked post i've submite here to rollback oculus software and get it work again.

Level 3

Will do...  if I ever get my headset back from them

currently downloading the files specified on your guide, will update as soon as possible 

Level 3

Apologies for the late response, work has been crazy.


here's my update

after multiple attempts I'm sad to inform that I had no luck trying to downgrade the firmware, the sensor check still fails, at this point, after some consideration and second opinions, I have come to the conclusion that the problem might be my USB ports the ones causing the problems, somehow? I'm planning to take my rig to a professional perhaps I can get some more info out of it. alas ill update once again eventually. 

Have you installed property driver of USB?

If yes,try using windows default driver.