cancel
Showing results for 
Search instead for 
Did you mean: 

PC Software Build 27.0 Release Notes

ShowbizDonkey
Oculus Community Manager
Oculus Community Manager

Oculus Link

    • Added a fix to reduce judder across multiple applications including Medium and Quill.
    • Improvements to microphone reliability.
    • Improved recovery flow for GeForce driver hangs on Pascal cards. For more information, visit https://support.oculus.com/572216283519517/ “Oculus Link isn’t working with my laptop.”
24 REPLIES 24

@chert1024VR  Probably right mate.  Interesting that Oculus seems to be restricting our graphics setting, taking out the previous top slider settings on both Q1/2.  Maybe this is to help improve stability for those that do not have powerful pc's.

 

I also just noticed that on the dashboard settings/graphics that neither AA or panel rendering does anything.  I usually only use the panel rendering because it seems to make all the home panels look nicer and does not cost much performance.  Now they look a little less sharp.  If you run task manager you'll see no change in %gpu with them on or off.  Again, maybe this is meant to improve stability for the masses.

 

Likewise, the reduction in usb3 data rates in v27 could be related to stability but I'm not sure how?  Maybe to stop people using too high ODT bitrates.

 

I gotta say that Link runs a lot smoother now and the graphics in apps still looks pretty good.  Maybe Oculus is just dragging us all down the the lowest common denominator, lol!

9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro


@Buetigame wrote:

Don't forget to let the drivers update!


What do you mean exactly? Shouldn't this be done automatically? I never saw a prompt asking me if I will allow the drivers to update. You mention "to let" which implies we have a choice also "not to let" them update. Or did you mean giving the Oculus software the chance/time to update its drivers automatically? I have read somewhere that the drivers had stayed the same for a long time, but that they were updated for v27. Please explain, because I would really like to get back to 90 Hz! Thanks! 

Buetigame
Level 5

There is a difference between Q1 and Q2 Link-rendering...

- Q1 = Downscaling on device

- Q2 = Downscaling on PC

And as described before... I'm using a Q2 and didn't have problems with refresh rates.

(didn't have any problem - beside the stuttering/high CPU-usage in Q2-Home, but not with Link/App Home)

tanubon
Level 5

I got PTC v28.0.0.222.469 now. 72hz bug was solved. But Link got new problems. lol

 

- Dynamic bitrate of debug tool (new feature) is strange. Even if I set 1000Mbps in it, the image has many encode noises like fixed 200Mbps. So it's just useless. And what's the meaning of "default" of dynamic bitrate? It has "default", "disabled" & "enabled". We need "default"?

 

- Sometimes horizontal line appear in the screen. The image above the line is good, but below is very whity & noisy.

IMG_1141.jpg

- The edge of screen (bottom) is cut off, and I can see a strange pattern. It's very noticeable & annoying.

IMG_1142.jpg

 

This problem is happened on encode resolution bigger than 3664.

5ephir0th
Level 2

Now with PTC V28 i cant even connect Link with my Quest 2 V27, was working perfectly before the update...

@tanubon 

Set dynamic bitrate to "disabled" and the screen problems should be gone

- default = depending on situation (oculus and apps decide)

- enabled = forcing it on in every situation 

- disabled = just turn it of and forget about it 😉

Your encode res width is 4080 (limit of Link) ? In current PTC v28, actual encode res width is a bit higher than the value of debug tool. So if we set 4080, Link won't work. We need to use around 4060 at max.

Nope. "Disabled" don't make anything difference. 😓

tanubon
Level 5

Distortion Curvature "Default" & "High" is the same in PTC v28.

 

Default

default.jpg

Low

low.jpg

High

high.jpg

 

"Default" & "Low" was the same in previous versions. Always strange. What are you doing?

 

 

And Encode Resolution Width has a bug, too.


3664 on debug tool, actual encode resolution is 3680.

4000 on debug tool, actual encode resolution is 4000.

4010 -> 4032

4030 -> 4032

4033 -> 4032

Higher than 4034 -> not work

 

Bug1: Input value & actual value don't match unlike previous versions.

Bug2: Max encode resolution width is lower than previous version. Previous versions were 4080.

420inPortland
Level 5

Still no fix for the Rift S post-Ver.25 USB/Controller/Crashing issues. I realize it's not officially supported, but they managed to screw it up completely right before they quit supporting it, as in 2 updates before that? I think all of us who bought one in the last yr or so deserve to at least have working hardware, mines only 5mo old !!!

Ryzen 7 1800X, Auros X470 Gaming Ultra, Power Color RX 580, 4200Mhz Corsair Hynix 32g, 500g Samsung 970 EVO (OS Drive), 1TB Silicon Power Gen 4 (Game Drive), Custom Water Loop