cancel
Showing results for 
Search instead for 
Did you mean: 

Rift S Black Screen and orange light

ecki386
Level 3

Hi,

I am having a problem with my Rift S in which it will black screen randomly, make a high-pitched beeping noise, and then I hear a static noise. My headset was working perfectly fine for 4 days, and now I can barely play games for more than 5 minutes. Sometimes when the crash occurs I get a windows notification saying that the DisplayPort isn’t connected, then that will randomly connect again. After it crashes, it goes back to a white light and my headset gets stuck on the black screen. I have to restart the Oculus software and try plugging everything back in for it to work.

I have tried these methods, and none of them work:

  • Repairing/Reinstalling the Oculus software
  • Reinstalling SteamVR + my games
  • Checking if everything is up to date (GPU Drivers, Oculus software, SteamVR, Windows 10) and they are
  • Tried every other USB 3.0 port on my PC
  • Disabled USB selective suspend setting in the Windows Power Options
  • Checked that the DisplayPort wire connection in the headset is connected properly
  • Ran the Oculus software in Administrator
  • Ending OculusDash.exe and OVRServer_x64.exe in task manager
  • Turned off Power Saving mode in Device Manager for all of my USB ports

The only other option I can find is turning off Razer Cortex, which I don't use.


These are my specs:

GPU : RTX 2070

CPU: AMD Ryzen 7 3700X

Memory: 32GB DDR4-3600

Motherboard: MSI B450 Tomahawk Max


Would be nice if there was a fix for this.

5 REPLIES 5

CobaltEight
Level 3
I hate to tell you but, the only fix I found was to RMA the headset. I dont know if its the headset or the cable but when I got my headset back two days ago everything was fine and I had the issue for over 7 months with zero permanent fixes. Even buying two usb exansion devices, one being an expansion card and the other being a power usb hub.

OculusSupport
Oculus Community Manager
Oculus Community Manager
Hi @ecki386 , Please create a support ticket here and we will be happy to assist you. - Clint

ecki386
Level 3


I hate to tell you but, the only fix I found was to RMA the headset. I dont know if its the headset or the cable but when I got my headset back two days ago everything was fine and I had the issue for over 7 months with zero permanent fixes. Even buying two usb exansion devices, one being an expansion card and the other being a power usb hub.


Oh damn I was just about to buy a powered USB hub, thanks for telling me! I'll try returning it later.

ecki386
Level 3


Hi @ecki386 , Please create a support ticket here and we will be happy to assist you. - Clint


I already started one two days ago, currently waiting for a reply.

hoppingbunny123
Level 8
the sharp points on the male usb must me pushed in. or the female socket flap that grips the sharp points on the usb male must be pushed in.

just pull them out again. like brand new. use a pair of tweezers and if that male usb is difficult to pull the sharp bits out, then just bend the usb metal tip in such a way the  sharp points jut out again.