Showing results for 
Search instead for 
Did you mean: 

Rift S Touch Controller positional tracking timeout on slow movements (

Level 3

As seen in the below gifs, there appears to be some sort of timeout for positional tracking of the new touch controllers. If I'm making slow movements, the touch controllers appear to be "lost" and cause massive issues with position; however, performing the exact same movement only a little faster produces no issues.

Steps to Reproduce:

  1. Install fresh batteries

  2. Restart Oculus Software via Settings -> Beta -> Restart Oculus

  3. Launch any software as long as you can see your hands

  4. Hold hand out in-front of you

  5. Begin turning very slowly as seen in below gifs

  • Expected Results: no tracking loss

  • Actual Results: tracking loss, but only on slow movements


Level 2
In the mean time I found that tapping my controllers when using a scope while tracking my target was one way to make sure the controllers do not freeze. Its not great but it works for me. 

Level 2
same here. ocbullus. garbage

Level 7
I think this problem is much more prevalent than people realize. I bet its happening right under everyone's noses, literally, without them noticing unless it matters for the game they are playing. They miss that shot or miss that beat and assume it was just their mistake.

I can recreate this in Oculus Home 100% of the time. Simply stick your hands out and rotate your body back and forth very slowly. Hands lose tracking and "reset" every couple rotations at least, sometimes multiple times on one rotation.
I also included this issue in an open ticket that I have. I even sent them videos of it happening in every oculus exclusive game and oculus home. They told me they were able to recreate the problem and the devs were working on it. That was maybe 4 months ago.
Oculus Rift S, CV1
Intel i7-8700K
ASUS ROG Maximus X Hero
16GB DDR4 x 2
Windows 10 Home

Level 2
The fact is that touch controllers stop sending any localization information after 2 seconds of "inactivity". 
just put one controller on your desk, and you can see the laser pointing disapear after 2 sec....
and its the same when you are "sniping".
Still searching for a solution...

Level 4
Wow! This problem is everywhere... This is sad, I've recorded a video myself:

Level 2
It's hard to imagine that after all this time the issue is still not resolved. What happened to people owning a gunstock and Rift S recently? I no longer see any complains or comments about this problem in the late 2020. They discovered the magic potion? Me I haven't and I'm still pissed by this frustrating problem. I upgraded to Rift S to enjoy a richer experience with my gunstock and I might have to resort getting back to my CV1 just because of this until Oculus disable the automatic power time-out on the Rift S controllers. My fear is that this day will never happen because I don't think that they've implemented this obnoxious power time-out just to be kind or convenient. They implemented it to mask an underlying flaw in the Rift S electronics and if they'd removed the time-out it would expose the hardware to unprecedented massive power consumption that r&d team didn't take the time to overcome before the kits were officially released on the market. That unfaithful habit has been seen many times over and even the great Oculus, for whom I have great respect by the way, could not escape from it. Please Oculus, prove me wrong. Release an update to offer the option to disable that tracking time-out function. There are more gamers using a gunstock than what you think. 

Level 4
Well i had the Hope that this issue was fixed on the quest 2 but guess what, is the same issue, a little less evident but as soon has i received my quest 2 i got onward for Quest 2 and tried with my protube gunstock and the same result

So i guess is something related to the tracking technology it self, like if when you put the gunstock it will lock the movement to the headset and your body and the movement is so small that the cameras on your headset cannot detect any more, contrary to the external camera tracking where even if you are very still the camera can detect those small variation because is not fixed to your body but to the wall.

the only "work around" i found is not fixing my controller to the gunstock but resting my hand on the cup base so that way you keep small movements enought for the camera to keep the tracking and still had a very good support for my hands to shoot more acurately.

maybe in a future generation of the tracking this will be fixed completely but for the quest 2 the problem is still there.


Level 4
by the way dont expect much from the quest 2 in graphics, onward looks like a N64 version, even the Downgraded PC version looks waaay better than quest 2 version.

Level 4
Just an Update at least for the quest 2 if you keep the grip button presed the tracking is never lost using the protuve, just select on your options of the game that you need to keep the grip button presed to keep the weapon on your hand, maybe this also work for rift s.


Level 2

2021 still no fix ?