cancel
Showing results for 
Search instead for 
Did you mean: 

Rift S USB connection is not working on startup replugin everytime

delobe
Level 3
Hi,
My rift S used to work fine until a couple of months ago. Now I have to unplug and plug it in again every startup (?!) to make the usb work.


I have now bought a pcie USB 3.1 5V3A card and plugged the rift s into this new powered usb port.

But the rift s still says usb connection is not working, and I have to unplug the cables and plug them back in EVERY TIME I start up my computer.

I do not believe this is what oculus said we would have to do when we bought their hardware? And the chance of breaking a usb/display port/cable by doing this is very high now and completely oculus' fault if this does happen.

I have installed the latest oculus drivers.

When I first bought and used the rift s I did not have an issue. It is, therefore, one of their updates that has caused this and is a very serious problem. There are many who have this issue on the forums.

Is there a fix out? I am definitely not going to recommend or consider buying from oculus in the future if this is how they update their hardware.
13 REPLIES 13

delobe
Level 3
Update: 

I decided to delete and uninstall the generic usb drivers and most of the other usbs in device manager.

On restart my computer opened oculus and recognised both usb and displayport as connected. (You would think this has solved the issue?) Oculus starts factory setting up my device with guardian. On ending guardian setup, the oculus dashboard in vr appears with a notification that the usb isn't working! But I still have access to the dashboard and can use the oculus and play games normally.

On restart  oculus still says that the usb isn't working but, in fact, I can now use my headset without unplugging and plugging back in the cables.

Very strange and fundamental bug that I hope oculus fix as it is destroying people's enjoyment of using the headset. I have seen quest owners with a similar bug, too.

Update 2:

After another restart back to having to unplug and plug back in.

Weird problem any oculus staff out there?

iDrika
Level 3
I'm having the same issue. Lucky you (sarcasm) yours work when you unplug and plug it back in lol. Mine won't work at all. It says USB isn't connected, then I change the USB port and it says nothing is working anymore (USB and Display port). So I unplug everything and plug it back in, it goes back to step one: USB isn't connected and the cycle goes on and on.
I spent literally two hours yesterday trying to fix this, restarted the pc several times, checked everything is up to date (graphics card, OS, drivers, etc), even changed the power supply plug (thought it could be power related - maybe the USB ports weren't getting enough power? But it wouldn't make sense as everything was working fine before and have only stopped working recently).
Funny thing is that after two hours trying everything possible and impossible, every reset, every port available on my pc (I've got a pretty decent gaming PC btw), it magically worked out of the blue, so I played Beat Saber for about an hour or so and if it were a hardware problem (i.e. faulty cable), it would break mid game for sure, as the cable moves as you play, and the game ran just fine. 
Game session is over. I turn off the PC. Next day in: TA-DAAAAAAAAAAAAAAAAAA, same 'USB not connected' shot. I don't know what to do anymore, this is SO annoying. It's been happening since Christmas. Is my device faulty or is it a software issue that only needs an update? I'm so mad I feel like crying brrrrrrrrr

OculusSupport
Oculus Community Manager
Oculus Community Manager
Hey there, thanks for taking the time to troubleshoot this issue extensively on your end. I can definitely see and respect your frustrations here, and we'd like to help you out. Can you please gather your Oculus Diagnostics Logs and submit them to us by clicking here? We'll be in touch to continue working on this with you. Thank you so much!

arrakisjabba
Level 2
Hey everybody, knowing the same problems i tried many things without success. So, i bought a 

ICY BOX USB 3.0 en Face Avant, 1x USB-C, 2X USB-A, SD et Lecteur de Carte microSD, 3, 5 Pouces Interne, métal, Noir 60433 + Lindy Rallonge DisplayPort 1m.

Now, everything is fine, the Headset is always recognized whitout the needed to unplug/plug many times i reboot.
It works for me and happy for that.

delobe
Level 3
Not sure how to report arrakisjabba above for spam post?

After lengthy diagnoses by oculus team product is being RMA'ed. No solution. It does work fine, the software just seems to believe there is something faulty when it is actually working normally.

nindivid
Level 2
I had same problem.. And all was gone when i bought and install ORIENT NC-3U2PE with additional power from MOLEX. 

delobe
Level 3
No way to report spam posts above?

Do not waste money on usb adapters, it is oculus problem not your pc. 

420inPortland
Level 5


Hey there, thanks for taking the time to troubleshoot this issue extensively on your end. I can definitely see and respect your frustrations here, and we'd like to help you out. Can you please gather your Oculus Diagnostics Logs and submit them to us by clicking here? We'll be in touch to continue working on this with you. Thank you so much!


Hey I have the exact same issue with my USB situation. Every time I go to play the USB is not readable, and sometimes the DP connector as well. I am sending my logs to you today.

Ryzen 7 1800X, Auros X470 Gaming Ultra, Power Color RX 580, 4200Mhz Corsair Hynix 32g, 500g Samsung 970 EVO (OS Drive), 1TB Silicon Power Gen 4 (Game Drive), Custom Water Loop 

420inPortland
Level 5
I have been having this issue since the day I got my rift S. I use OTT to stop the service when not in use, but it makes no difference whether I use it or not. The problem persists either way. I will send my logs maybe I can also get an RMA?OculusSupport said:


Hey there, thanks for taking the time to troubleshoot this issue extensively on your end. I can definitely see and respect your frustrations here, and we'd like to help you out. Can you please gather your Oculus Diagnostics Logs and submit them to us by clicking here? We'll be in touch to continue working on this with you. Thank you so much!



Ryzen 7 1800X, Auros X470 Gaming Ultra, Power Color RX 580, 4200Mhz Corsair Hynix 32g, 500g Samsung 970 EVO (OS Drive), 1TB Silicon Power Gen 4 (Game Drive), Custom Water Loop