cancel
Showing results for 
Search instead for 
Did you mean: 

Rift S USB connection is not working on startup replugin everytime

delobe
Level 3
Hi,
My rift S used to work fine until a couple of months ago. Now I have to unplug and plug it in again every startup (?!) to make the usb work.


I have now bought a pcie USB 3.1 5V3A card and plugged the rift s into this new powered usb port.

But the rift s still says usb connection is not working, and I have to unplug the cables and plug them back in EVERY TIME I start up my computer.

I do not believe this is what oculus said we would have to do when we bought their hardware? And the chance of breaking a usb/display port/cable by doing this is very high now and completely oculus' fault if this does happen.

I have installed the latest oculus drivers.

When I first bought and used the rift s I did not have an issue. It is, therefore, one of their updates that has caused this and is a very serious problem. There are many who have this issue on the forums.

Is there a fix out? I am definitely not going to recommend or consider buying from oculus in the future if this is how they update their hardware.
15 REPLIES 15

psyk92
Level 2
Same problem.

I need help same problem 

Arland.snv
Level 2

I have the same problem, any working solution yet.??

Lestart_D_Grave
Level 2

Same Problem here i tried everything the oculus support recommended but it still happens 😧

 

but it's really strange i was searching about this problem on google and i found many people with the same problem and i think it is a little odd that oculus still didn't fixed this problem 😞

 

i mean i have this problem with my Rift S since over 2 years 😧

Lena965
Level 2

Same issue; tried plugging the cable into all of the USB 3.0 slots on my computer and still no dice. I'd get another cable to replace it but I can't because they aren't being sold anymore.

great.

HSken
Level 2

Where are some tips that helped me
https://uploadvr.com/how-to-fix-rift-s-tracking/

Also using use Oculus Tray Tool this solves a lot of issues for you or makes it possible to switch between energie modes...

Also try other USB ports or check your manual and use the fastest one, I for example have some usb 3.0  and two usb 3.1 ports on my mainboard