cancel
Showing results for 
Search instead for 
Did you mean: 

Rift S USB connection is not working on startup replugin everytime

delobe
Level 3
Hi,
My rift S used to work fine until a couple of months ago. Now I have to unplug and plug it in again every startup (?!) to make the usb work.


I have now bought a pcie USB 3.1 5V3A card and plugged the rift s into this new powered usb port.

But the rift s still says usb connection is not working, and I have to unplug the cables and plug them back in EVERY TIME I start up my computer.

I do not believe this is what oculus said we would have to do when we bought their hardware? And the chance of breaking a usb/display port/cable by doing this is very high now and completely oculus' fault if this does happen.

I have installed the latest oculus drivers.

When I first bought and used the rift s I did not have an issue. It is, therefore, one of their updates that has caused this and is a very serious problem. There are many who have this issue on the forums.

Is there a fix out? I am definitely not going to recommend or consider buying from oculus in the future if this is how they update their hardware.
20 REPLIES 20

psyk92
Level 2
Same problem.

Anonymous
Not applicable

I need help same problem 

Arland.snv
Level 2

I have the same problem, any working solution yet.??

Lestart_D_Grave
Level 2

Same Problem here i tried everything the oculus support recommended but it still happens 😧

 

but it's really strange i was searching about this problem on google and i found many people with the same problem and i think it is a little odd that oculus still didn't fixed this problem 😞

 

i mean i have this problem with my Rift S since over 2 years 😧

Lena965
Level 2

Same issue; tried plugging the cable into all of the USB 3.0 slots on my computer and still no dice. I'd get another cable to replace it but I can't because they aren't being sold anymore.

great.

HSken
Level 3

Where are some tips that helped me
https://uploadvr.com/how-to-fix-rift-s-tracking/

Also using use Oculus Tray Tool this solves a lot of issues for you or makes it possible to switch between energie modes...

Also try other USB ports or check your manual and use the fastest one, I for example have some usb 3.0  and two usb 3.1 ports on my mainboard 

Clarion-Z
Level 2

same issue. Got Rift S yesterday and have to replug both connections every time after rebooting computer to get it to work

Gazz1e
Level 2

Same issue here. Only had my Rift S for a few days and disappointed about the quality of the Oculus software not detecting the headset being plugged in. Only reconnecting fixes it and that's not a solution. 

 

I've tried the tray utility someone mentioned and that doesn't help.

 

Really unimpressed.

So, I got my issue solved. No idea if this will help everyone but here's what I have and how i got it working.
First of all, I've had Inatek USB 3 PCI expansion card installed for a long time now. Had RIFT CV1 installed on that and it worked nicely. However, Rift S refused to work at all with that. 
So I had Rift S on motherboard USB 3.2 slot and it "worked" there with the boot connection issues. 

Now, I tried things bit differently. I wondered if there's a power delivery issue as some people say that powered USB hub helps. So I moved all the other USB devices away from the Motherboard USB 3's to the expansion card.

Not a fix yet...
But mother board has 2xUSB 3.2 connected to chipset and 2xUSB 3.1 claimed for CPU. Having the Rift S on the 3.1 cpu slot works. 100% connection on reboots now. Just to make sure, I've done multiple shutdowns and start ups.
I was also going to try disabling powersavings but apparently that's not needed anymore. 
I don't know if this is the actual fix or the planets are just aligned perfectly for RIFT S now, but works now and hopefully some of this will help you guys. 

 

Edit: and a little tracking stutter i've had is gone as well now.

Zetmet
Level 2

Das gehört auch zu meinem Problem und sie geht während des Spielen aus und es wir gemeldet das mein disportkabel nicht angeschlossen ist also nach solchen Problemen kann ich die Hardware von oculus nicht empfehlen