Showing results for 
Search instead for 
Did you mean: 

Rift S USB connection not working

Level 2
Hi there!

Since a while it's impossible for me to connect my Oculus Rift S, because of the USB 3.0 connection issue.
I tried already so many troubleshootings and also the official oculus support couldn't help me so far. It seems to be a software problem with the oculus software or a conflict with a windows update.

System specifications:

  • OS: Microsoft Windows 10 (10.0) Professional 64-bit (Build 19041)**
  • CPU: Intel(R) Core(TM) i5-9600K CPU @ 3.70GHz
  • GPU: NVIDIA GeForce RTX 2060
  • Mainboard: ASUSTeK ROG STRIX Z390-F GAMING
  • RAM: 16GB DDR4
  • Drive: SSD Samsung Evo 500GB
  • Oculus:
  • Software: I'm a developer so I have installed dev tools like yarn, npm, docker, VM, ... maybe this a problem?
**Windows Version
Edition Windows 10 Pro
Version 20H2
Installed on ‎16.‎10.‎2020
build 19042.630
Windows Feature Experience Pack 120.2212.31.0

What I've tried already:
  1. Followed Official Oculus Troubleshootings, e.g. this video: htt ps : / /w w w .you
  2. Unplugged and re-plugged USB and Displayport a couple of times. First the USB and after seeing a white light, connecting the Display Port. After a while the white light turns into a red light and the software tells me a usb connection problem. Or in setup the headset it will tell me after a while sensors can't track headset  
  3. Unplugged and re-plugged cable on the headset
  4. Tried all USB ports (USB 2.0 connection works, but then it tells me, I have to use USB3.0)
  5. Tried the headset on a different PC, which worked, so the cable is fine!
  6. Installed newest graphic drivers and windows updates
  7. Restarted the Oculus software and ended all the background services (Oculus Runtime, etc.) 
  8. Turned off USB power saving settings (Windows settings)
  9. Deactivated Windows Gamemode (Windows Settings) 
  10. Deactivated all Windows Security (Real time protection, Cloud delivered protection, Windows Defender firewall, Automatic sample submission) 
  11. Disconnected all USB devices except mouse, keyboard, one monitor and rebooted windows 
  12. Uninstalled all Oculus applications and removed all folders*
  13. Reinstalled newest oculus software
  14. Registered to Oculus public test channel (oculus/settings/beta)
  15. Used a brand new internal PCIe USB 3.1 Superspeed Card (10Gbps) (Inateck, ASMedia)
  16. Tried external USB 3.0 Hub with own power connection
  17. Sent my pc specifications and oculus logs by using OculusLogGatherer to official oculus support: htt p s : / /s upport. o culus.c om/172672339980954/

* folders removed:
  •  C:\Users\USERNAME\AppData\Local\Oculus\ 
  • C:\Users\USERNAME\AppData\Local\Temp\OculusSetup\ 
  • C:\Users\USERNAME\AppData\LocalLow\Oculus\ 
  • C:\Users\USERNAME\AppData\Roaming\Oculus\ 
  • C:\Users\USERNAME\AppData\Roaming\OculusClient\ 
  • C:\OculusSetup-DownloadCache 
  • C:\Program Files\Oculus 

  • venturebeat: http s://ven turebeat .co m/2019/0 5/26/oculus-rif t-s-how-to-fix-tracking-problems-and-blackouts/
  • Reddit: htt ps:/ /w ww . redd it. com/r/ocu lus/comment. s/e1sdy3/oculus_rift_s_no. t_detecting_usb_or_displayport/?utm_medium=android_app&utm_source=share
  • Youtube - dbcrazycat: htt ps : / / w ww. youtube .com /watch?v=mDKbcc3ysjc&ab_channel=dbcrazycat 
  • vrforum (german): htt ps : / /v rf orum.d e/th reads/l%C3%B6sung-oculus-rift-s-funktioniert-nicht.8549/

I've got no more ideas now, but maybe anyone has more tipps for me?
At least I hope that this troubleshootings are helpful for someone else.


Level 3
might be the same ASMedia driver issue I'm having.

Level 3
FYI - when I forced an update to ASMedia extensible host 3.1 driver using the latest from the Microsoft website, it cleared out all driver issues and now my Oculus connects.  Hope this thread helps someone else.  Frustrating that Windows says the driver is up to date, but Microsoft has a newer driver that solves this issue.  You have to force the update with "have disk" too.

Level 2
Nice, thanks for this.
Anyway, I actually have to reconnect the oculus everytime after restart my PC but than it worked fine. It seems like the latest oculus update fixed also some problems.