cancel
Showing results for 
Search instead for 
Did you mean: 

Rift S black screen issue - Been trying to fix this for a month now; any ideas?

LG1816
Level 2
Hi.
I'll start with my system specs, as it's a little unorthodox and may well be implicit in the issue.
It's a Mac Pro for a start, running Windows 10 on a separate drive (I've PC gamed on this setup for a few years now)
It has an Intel W3680 six core CPU, 16gb of RAM and an Nvidia RTX 2070 Super.
For the first week I got my Rift S everything was running perfectly. I ran everything on max settings and it was awesome.
Randomly one day, I plugged everything in, got green lights on all and the blue light on the front of the headset, but when looking through the lenses there was nothing but a black screen (and when I say black screen, there was no backlight; the screen was just off). 
 Putting the headset on triggered a prompt that the headset was not working properly and also that the headset had no audio, despite that not being the case and all of my systems audio being routed through it. The display on Oculus home then told me I needed to restart the Oculus software, which I did several times but the same issue presented. 
The Rift S is plugged in via Display port directly to the GPU, and the USB is connected to a Renesas PCI-e USB hub.

I've done extensive trouble shooting:
I tested the headset on a different PC and it worked fine, so the headset is working no problem.
I tried changing USB power modes, re-installing the Oculus software, re-seating the cable that plugs into the headset, updating the firmware, updating graphics card drivers, updating USB drivers. None of it worked. 


I know the CPU is not officially to the right spec for running the Rift, but it worked perfectly for a whole week before. I know it isn't the headset as it works on other systems, and it was none of he classic troubleshooting steps. The only thing I haven't done yet is reinstall windows. It seems to me that it's some sort of software issue; something updated that it didn't like, and now it doesn't work. That's the only thing I can think of, anyway.
I'm considering driver rollbacks for my GPU to see if that works. Someone also mentioned the possibility that one of my components has been recently black listed to work with Oculus, though I'm unsure as to the validity of that possibility. 

Has anyone any suggestions of what this might be or what else I could do to trouble shoot it?

Many thanks.
3 REPLIES 3

LG1816
Level 2
I should add that It on the other PC yesterday and the headset did actually do the same thing, but it was resolved there by restarting; a solution that doesn’t work on The computer in question. 

Antman5407
Level 2
I have the same issue worked for the first hour of me getting it but after it just went black. Did you find a fix yet?????

mangirlchild
Level 2
same im having that issue but i never got it to work in the first place lol