cancel
Showing results for 
Search instead for 
Did you mean: 

Rift S blackscreen

Hey there! I have a Rift S that worked fine till today when i tried to use it the screen just stayed black. no sound. the software didnt pop up on the desktop screen. not even the backlight turned on. the little LED on the headset was white showing it was connected with the software. i tried resetting the software and tried to setup the headset again. Oculus software said the connection (USB and DP) was fine and the sensors seemed to wor too. but when trying to connect the controllers the software couldnt find them. i am stuck. i dont know what else to try.

 

Also when i disconected the headset while the software was running. nothing happend. Oculus still showed the headset as connected.

13 REPLIES 13

cliff1960
Level 4

simular prob but with me all i get is a grey oval with 3 white flashing dots in it. plus constant USB plugged into USB 2 port please plugin to a USB 3.  i dont have any USB 2 ports only USB 3, 3.1 and 3.2. tried all of them then once that recoginises its plugged in its DP port not connected. Everything worked fine yesterday no probs at all.

 

Its not my rig as its a new build done last month. new motherboard, CPU RAM PSU GPU the lot all replaced.

zeekius
Level 2

Same problem, was working fine for a year, bought a new gaming laptop last month, was working perfectly fine on that too.

i tried to play today after a 2 week break and the screen is black, the led is on and white, the sound is there, i react's to my controllers and i can hear them.

the problem is on both machines, tried to update gpu. oculus and windows drivers.

Welcome to the club, we have cookies, not working headsets and I still haven't found a reliable solution to this, but cookies.

Sometimes restarting Oculus software works for me via settings -> beta, sometimes it doesn't, sometimes you have to restart it 5 or 6 times, sometimes restarting the whole PC works, sometimes unplugging and replugging it will, but lately even when I do all those and finally get past this it doesn't matter because then the controller tracking breaks after 10 minutes. If none of those work, sometimes I've been able to get it to temporarily work by restarting the OVR runtime service myself through services. Oh and I know at least for me, the device status tab is completely useless, might as well just ignore it, it virtually never reports accurately whether anything is working.

 

So you can try those things possibly and see if you get lucky, otherwise I'm not sure what else can be done. (Aside from, you know, avoid Oculus products)

i tried all those things before posting on here lol.

 

Had the same probs with both the CV1 i had before. oculus support just says buy a new cable.

Yeah right maybe if they sold cables we might be able to try that lol.

 

but i tried that as well. bought a 2nd hand CV1 which was cheaper than getting a cable as all the ones i saw for sale were over £200 and bare wires all over the place lol and put that cable on my old CV1 and it fixed it for a few days before it went again. so put the cable back on the newer CV1 and tried it and it worked on that for a few months.

so that proved it wasnt a cable problem.

 

So its either a screen problem or a software problem. But as most of the problems start after a software update my money is on software.

 

From other posts its not cause it hasnt been linked to facebook as those that have, have even more probs than the ones who havnt.

i have tried to restart the software via the beta tab. it did nothing. the software just stayed. did not restart

 

Yeah I have that same problem sometimes too. The only things I've found to do are

1) Click the restart button again and wait a few minutes (the dialog does say 30 seconds to be fair may be needed but I swear sometimes it's much longer)

2) Give up and go find OVR runtime service in windows services and restart it from there directly

Mysticacorn117
Level 3

yeah same i just got a black screen i did rest it and stuff nothing worked 

check the ovrlibrary service.log in file explorer. ive just noticed this i there. IPC connection destroyed.

 

so basicly the HMD cant connect to ur PC for some reason hence why it doesnt boot up.

 

[Debug] [06/08/2021 23:11:23] Starting up OVRLibraryService v1.16.0.0.
[Debug] [06/08/2021 23:11:23] Starting up.
[Debug] [06/08/2021 23:11:24] IPC connection opened.
[Debug] [06/08/2021 23:11:24] IPC thread running; waiting for Oaf to connect.
[Debug] [06/08/2021 23:11:24] App libraries for this user: [CORE_DATA]
[Debug] [06/08/2021 23:11:24] OVRLibraryService starting in service mode. Arguments: [migrate, enable-uwp]
[Debug] [06/08/2021 23:11:24] IPC connection established!
[Debug] [06/08/2021 23:11:24] Creating NTFS transaction.
[Debug] [06/08/2021 23:11:24] Adding UWP permissions to Oculus directory.
[Debug] [06/08/2021 23:11:24] Committing changes.
[Debug] [06/08/2021 23:11:24] IPC connection destroyed.
[Debug] [06/08/2021 23:11:24] Exiting with code 0 (Success).

 

Havnt a clue what that means still looking around the net to see if i can find a solution.

cliff1960
Level 4

also look in event viewer. im getting lots of OVR launcher error's. no error code but says setGPUpriotyclass target process didnt respond in time.

 

So to me it looks like the app is having trouble conneting to the GPU. could be why the HMD is getting black screens but getting sound.