cancel
Showing results for 
Search instead for 
Did you mean: 

Rift S display port issues. Need help!

payt69
Level 4
Hi fellow VR enthusiasts,

I december of 2019 I bought an Oculus Rift S. back then, I still had my 'old' computer, which consisted of a I7 930, 16 GB DDR3 ram, and an RTX2070. The Rift worked mostly fine on this. Occasionally there would be some connection issues, but those could be resolved by deleting the USB Rift S entries in the device manager, and then replugging the Rift S. This has happened about 2 times.

Sice my old PC was a bit outdated, and Oculus home complained that my CPU was too slow, I ordered a new computer, consisting of an Asus Z390-P mobo, I5 9600K processor, 16GB DDR4 ram, Corsair VS650, and of course the RTX 2070 again.

After installing windows 10 on this machine and updating windows and all the drivers, I installed Oculus home, connected the cables, and everything worked like a charm. It's been working like that for some 2 months, until 3 days ago my PC started acting up. It would freeze occasionally, sometimes for 10 or 20 seconds, and then it'd sortof start working again. Of course I rebooted the pc, and then it;d work for a bit, and then the freezes would start again. It was around this time that Oculus home started complaining that the display port couldn't be found.

After a while it seems that the PC wouldn't start up at all. The fans would spin, the lights come on, but sometimes it would beep a sequence indicating that there's something wrong with the video card, and the monitor would say there isn't a video signal.

I was finally able to determine that the HDMI cable I was using was probably at fault, so I replaced that, and my PC has been running like a dream ever since. However, one problem still persisted, and that was that OCulus didn't recognize the Rift S' display port cable anymore.

So of course I started perusing google to see if anyone else has this problem, and I ran into all sorts of suggestions that might help. I tried using different USB ports, both display ports, I tried updating all drivers I could think of, and at one point even reinstalled my windows 10 from a completely clean SSD, followed by more reinstalling of most recent drivers for everything, but the problem of Oculus not recognizing my display port cable for anything more than 5 seconds persists.

And that's the weird thing: when I insert the DP cable, the icon turns green for about 5 seconds, after which it goes off again and Oculus tellms that there's no DP connection.

So it DOES see something. And the USB connection is flawless. It detects the cable in both DP ports, but in both cases switches off again after about 5 seconds.

I even tried reverting the version of the Oculus firmware to 2.1.1, as well as reverting NVidia software to a previous version. Nothing works.. not even for a bit!

Here are some hypotheses of what I think COULD be the case:

- Power supply doesn't provide quite enough power for the GPU. It works flawlessly in games and all that. but maybe the DP port needs to provide too much power to the Rift S. So when you plug in the cable, it's enough for it to detect the cable going in, but not enough to sustain the connection. This would have to be case for gazillions of other people with different GPU's and different PC configurations though,m since many people have the same problem.

- The faulty HDMI cable fried something in the GPU which now results in the DP not functioning properly. However, with the new HDMI cable the GPU works flawlessly, and it would have to have affected both DP ports equally.

- Something could be wrong with the Rift S or it's cable. I've tried reseating the connector that goes into the Rift S, and made sure it went in as far as it goes. I tried to find any dents or cable breakage, but everything looks fine and should work.

I'm going to try and see what happens when I use a different video card, but I have to borrow it from someone. If that doesn't work, I'm going to try and see what happens if I supply the GPU with power from a different PSU. I'll also try and see if I can get the Rift S to work on a different PC.

Looking through these forums and other sources though, it becomes clear that many many people are dealing with this same issue. Oculus seems to acknowledge that something is wrong somewhere between the software and the Rift S, but it hasn't become clear what it could be yet. They do say that they're looking into it, but haven't been open on what their progress is or what their findings so far are. Instead they provide people with a standard list of things to do, such as trying different USB ports, reinstalling software, drivers, etc etc. It has become clear that no PC configuration is exempt from these problems. In fact the only common denominator is the Rift S and the Oculus software, as far as I can see. 

It's been a very frustrating experience. One day everything works perfectly, the next day it's all gone without a hint of how to make it work again.

I've been a pretty vocal advocate of VR in general and the Rift S specifically, but now I'm afraid I have to advise people against it. It could be that all Rift S users are sitting on a time bomb!

Anyway here' hoping for the best. If anyone has the golden tip on how to solve this, I'd love to find out! Keep in mind I've tried all the standard stuff already though!

Cheers,

Peter
52 REPLIES 52

TK_Prince
Level 4
l1hofx8ecuty.pngI find another strange thing, why Displayport connection error stay when the Rift is NOT connected ?!

TK_Prince
Level 4
This is all errors I get when I plug my Rift S, if that could help.

And this one too : 26/06 20:07:18.974 {!ERROR!} [KMHealth] Audio device not found via pc_hal_get_audio_id

@OculusSupport

swffft4oeyny.png

Honosuseri
Level 4
Just to keep people up to speed with my experience...

Had the same issue over the Display port and was told to return the HMD. Oculus received my Rift S back on 19th June, probably took 4 days to get to them though. 29th of June I was told my order was processed, 1st of July I got a "sales invoice" telling me the HMD was on it's way. Received a WORKING Rift S today on the 2nd of July

jjGuardian
Level 3
Brand new machine I just received yesterday (July 16th, 2020). Fresh install of Windows 10. Fresh install of everything!

My issue is some kind of issue with USB 3.2 Gen 1.
Importantly, I am able to connect my Rift S to BOTH displayports on my ROG Strix 2080 TI and both connected devices  work. I'm running a Samsung LC49RG ultra wide 49" @5120x1440 and the Rift S off the same card... BUT

I thought all was working fine, played a DCS (Which doesn't require the Oculus controllers) and life was OK BUT noticed my tracking was only working for left/right/up/down head movements not forward and back, so I jumped out to my Oculus room and found my controllers tangled together and only their rotation movement being tracked. I couldnt get the controllers to leave the one spot they were in. (Tracking issue)

I ran the setup. Both the Displayport and the USB pass in step 1. Step 2 completely fails with complaints of USB problems and asks me to disconnect the USB and try another port. None resolve the issue.

I went back to the machine I'm replacing, an Alienware area 51 R2 and tried the Rift S there. Worked perfectly on the first attempt. No tracking issues at all.

All of the USBs on my old Alienware Area 51-R2 are USB 2.0 and 3.0. All USBs on my new machine are USB 2.0 and 3.2 gen 1. Since the USB test passes the USB 3.2 Gen 1 connection but the tracking fails with USB complaints, I'd have to conclude the Rift S isn't fully compatible with the USB 3.2 Gen 1.

I do have external storage devices attached which require USB 3.0 or higher and they are working very happily.

My system is a Ryzen 9 3650, 16 core.
ROG Strix Nvidia 2080 TI with 11 gb ram
64 Gb ram @ 3600 Mhz
2 Tb SSD C drive
4 Tb D drive
Oculus core is installed on the SSD with downloadable games on D

Arquire
Level 2
Any update on this guys, I am still having these same issues

thacleaner
Level 2
dont know if it helps but i had the problem that either i had to reconnect USB 1000x times (with a high speed AC powered USB hub) or when it connected it would fail the sensor settings.

what i did is to go to my laptop manufactureres website and download the USB drivers (Texas Instruments Drivers for ASUS ROG G703) and now it works like a charm.

it said display port not connected, sensors failed, USB not recognized and every possible problem there could be but in the end it was the USB Drivers.

(The Driver description said it fixes a problem with power support for USB-C..)

thacleaner
Level 2
USB-Ports on my notebook are:

3 x USB Type-A 3.1 (Gen.2)
1 x USB Type-C 3.1 (Gen 2)

Connected via mini Display Port with the provided converter
hope this helps


mrmattsir
Level 2
Just wanted to add to this myself since I'm having some similar issues. 

My old PC ran my Rift S fine without any issues whatsoever. 
  - MSI x370 Gaming Pro Carbon
  - Ryzen 7 1700x
  - 16GB 2933 DDR4
  - GTX 1070
  - 650W PSU

But my brand new system is having issues. 
  - Asus ROG Strix x570-e
  - Ryzen 7 5800x
  - 32GB 3600 DDR4
  - RTX 3070
  - 850W PSU

Occasionally the Oculus app will tell me my "DisplayPort is not working". If I unplug the DisplayPort connection and plug it back in, the Oculus app will show the green checkmark for a few seconds and then go back to saying the DisplayPort is not working. Frustrating, but a system restart usually resolves that specific issue. 

My main problem is that when playing certain games, after about 15 minutes or so everything will freeze, the sound will cut out, and the game will crash. Sound is just completely gone, even in the Oculus home, until I restart the Oculus app. 

I have 2 monitors also connected to my GPU, a 3440x1440 60hz, and a 1440p 144hz. I need to test playing without them connected, but if my old GTX 1070 could handle all 3, I don't understand why this card wouldn't be able to...

I have also heard some people say that ASMedia chipsets can have some compatibility issues. And I've also heard that USB 3.2 gen 2 backwards compatibility for the headset isn't great...? ALL of my USB outlets are USB 3.2 gen 2, so I can't even test if that's a possible issue. Also not sure how true any of these claims are, cause anyone can say anything on the internet. 

For a while I thought it was a power delivery issue from the USB side, but then I read that the headset uses about 5v and USB 3.2 gen 2 offers up about 20v, so... Surely that can't be the issue... right?

Been working with Oculus support for a few weeks now, it's very slow going. Lots of very generic questions, like "is the cable damaged" and stuff. So tired of the anticipation anxiety and I just want to know what's going onnnn

jamsimmer99
Level 2
Problems: Windows has stopped this device because it has problems (code 43)
Solutions:
In general, the specifications for a USB 1.0 and 2.0 standard downstream port, delivers up to 500 mA or 0.5A.
Not enough to make the Rifts working as it will be in this configuration.
Also, with a USB 3.0, it can provide up to 900mA or 0.9A, which translates into 4.5 watts.
These power output specifications are a rating based on the 5 volts from each standard output.The Oculus Rifts
headset need as a standard requirement power of 4.5 watts.The tracking cameras require a lot of this power. So as we can see there is very little margin to compensate for the 5 meters
length of the cable connected to the USB3.0 port. Also if you use several USB devices on the master card the power
of 4.5 watts is reduced to make the Rifts it messy. So the solution is to use a USB3.0 hub powered by an external
source that can supply 5 volts at 2A (10 watts) connected to the output of a USB3.0 port of the PC. That's it.

luke_harvey_54
Level 3
Reading this thread it sounds like I have the same issues, and nearly a year later from the original post there is still no fix for it what so ever?