cancel
Showing results for 
Search instead for 
Did you mean: 

Rift S display port issues. Need help!

payt69
Level 4
Hi fellow VR enthusiasts,

I december of 2019 I bought an Oculus Rift S. back then, I still had my 'old' computer, which consisted of a I7 930, 16 GB DDR3 ram, and an RTX2070. The Rift worked mostly fine on this. Occasionally there would be some connection issues, but those could be resolved by deleting the USB Rift S entries in the device manager, and then replugging the Rift S. This has happened about 2 times.

Sice my old PC was a bit outdated, and Oculus home complained that my CPU was too slow, I ordered a new computer, consisting of an Asus Z390-P mobo, I5 9600K processor, 16GB DDR4 ram, Corsair VS650, and of course the RTX 2070 again.

After installing windows 10 on this machine and updating windows and all the drivers, I installed Oculus home, connected the cables, and everything worked like a charm. It's been working like that for some 2 months, until 3 days ago my PC started acting up. It would freeze occasionally, sometimes for 10 or 20 seconds, and then it'd sortof start working again. Of course I rebooted the pc, and then it;d work for a bit, and then the freezes would start again. It was around this time that Oculus home started complaining that the display port couldn't be found.

After a while it seems that the PC wouldn't start up at all. The fans would spin, the lights come on, but sometimes it would beep a sequence indicating that there's something wrong with the video card, and the monitor would say there isn't a video signal.

I was finally able to determine that the HDMI cable I was using was probably at fault, so I replaced that, and my PC has been running like a dream ever since. However, one problem still persisted, and that was that OCulus didn't recognize the Rift S' display port cable anymore.

So of course I started perusing google to see if anyone else has this problem, and I ran into all sorts of suggestions that might help. I tried using different USB ports, both display ports, I tried updating all drivers I could think of, and at one point even reinstalled my windows 10 from a completely clean SSD, followed by more reinstalling of most recent drivers for everything, but the problem of Oculus not recognizing my display port cable for anything more than 5 seconds persists.

And that's the weird thing: when I insert the DP cable, the icon turns green for about 5 seconds, after which it goes off again and Oculus tellms that there's no DP connection.

So it DOES see something. And the USB connection is flawless. It detects the cable in both DP ports, but in both cases switches off again after about 5 seconds.

I even tried reverting the version of the Oculus firmware to 2.1.1, as well as reverting NVidia software to a previous version. Nothing works.. not even for a bit!

Here are some hypotheses of what I think COULD be the case:

- Power supply doesn't provide quite enough power for the GPU. It works flawlessly in games and all that. but maybe the DP port needs to provide too much power to the Rift S. So when you plug in the cable, it's enough for it to detect the cable going in, but not enough to sustain the connection. This would have to be case for gazillions of other people with different GPU's and different PC configurations though,m since many people have the same problem.

- The faulty HDMI cable fried something in the GPU which now results in the DP not functioning properly. However, with the new HDMI cable the GPU works flawlessly, and it would have to have affected both DP ports equally.

- Something could be wrong with the Rift S or it's cable. I've tried reseating the connector that goes into the Rift S, and made sure it went in as far as it goes. I tried to find any dents or cable breakage, but everything looks fine and should work.

I'm going to try and see what happens when I use a different video card, but I have to borrow it from someone. If that doesn't work, I'm going to try and see what happens if I supply the GPU with power from a different PSU. I'll also try and see if I can get the Rift S to work on a different PC.

Looking through these forums and other sources though, it becomes clear that many many people are dealing with this same issue. Oculus seems to acknowledge that something is wrong somewhere between the software and the Rift S, but it hasn't become clear what it could be yet. They do say that they're looking into it, but haven't been open on what their progress is or what their findings so far are. Instead they provide people with a standard list of things to do, such as trying different USB ports, reinstalling software, drivers, etc etc. It has become clear that no PC configuration is exempt from these problems. In fact the only common denominator is the Rift S and the Oculus software, as far as I can see. 

It's been a very frustrating experience. One day everything works perfectly, the next day it's all gone without a hint of how to make it work again.

I've been a pretty vocal advocate of VR in general and the Rift S specifically, but now I'm afraid I have to advise people against it. It could be that all Rift S users are sitting on a time bomb!

Anyway here' hoping for the best. If anyone has the golden tip on how to solve this, I'd love to find out! Keep in mind I've tried all the standard stuff already though!

Cheers,

Peter
53 REPLIES 53

yeah its sad ,  ive had my rift s for 2 years and ever since the 2.2 its had nothing but these issues ,  I even bought a brand new gaming laptop just for the oculus and guess what ?!   The same freaking issue !    Im so sick of them not coming up with a fix for this !   Can anyone recommend a good VR headset that isnt the Vive ?   Im pretty much at my wits end with this issue , obviously they have no intentions on fixing it

yungprankster
Level 2

I just had this issue last Friday and Support has been silent on what to do ever since I sent the logs. I'm pretty sure we did our job, though, guys. We bought the product. We consumed.

ToMuchLogan
Level 2

I was having this problem earlier but now it is just showing a red "x" whenever i plug in my display port, i dont know if this helps

Jrcftll
Level 2

same here, had rift s for about 10 months, one day it decided to tell me my display port isnt working! ive tried all solutions and everyone tells me, GET a usb hub/card.. and im like really? if i ran the **bleep**ing thing for 10 months with no issues, then why or how is it anything other then a software/hardware issue with the headset, i dont think ill be getting a replacement, and with doing all the work arrounds and headaches this has been. even getting some of the things to work as intended, and the horrible oculus app thats intrusive. i can for sure, next headset not being going with oculus, and im not racist, but when it comes to headsets i am now... not all headsets are the same.. if it is a firmware issue *started after an update. then it only makes sense. dis continue rift s, and throw all of us in the dirt.  wonderfull... ive concluded its a faulty cable, but is 2021 and rift s  parts or even the concept of getting a new rift is rather obsolete. Horrible practice.. i didnt spend 600 bucks for a paper weight