cancel
Showing results for 
Search instead for 
Did you mean: 

Rift S display port issues. Need help!

payt69
Level 4
Hi fellow VR enthusiasts,

I december of 2019 I bought an Oculus Rift S. back then, I still had my 'old' computer, which consisted of a I7 930, 16 GB DDR3 ram, and an RTX2070. The Rift worked mostly fine on this. Occasionally there would be some connection issues, but those could be resolved by deleting the USB Rift S entries in the device manager, and then replugging the Rift S. This has happened about 2 times.

Sice my old PC was a bit outdated, and Oculus home complained that my CPU was too slow, I ordered a new computer, consisting of an Asus Z390-P mobo, I5 9600K processor, 16GB DDR4 ram, Corsair VS650, and of course the RTX 2070 again.

After installing windows 10 on this machine and updating windows and all the drivers, I installed Oculus home, connected the cables, and everything worked like a charm. It's been working like that for some 2 months, until 3 days ago my PC started acting up. It would freeze occasionally, sometimes for 10 or 20 seconds, and then it'd sortof start working again. Of course I rebooted the pc, and then it;d work for a bit, and then the freezes would start again. It was around this time that Oculus home started complaining that the display port couldn't be found.

After a while it seems that the PC wouldn't start up at all. The fans would spin, the lights come on, but sometimes it would beep a sequence indicating that there's something wrong with the video card, and the monitor would say there isn't a video signal.

I was finally able to determine that the HDMI cable I was using was probably at fault, so I replaced that, and my PC has been running like a dream ever since. However, one problem still persisted, and that was that OCulus didn't recognize the Rift S' display port cable anymore.

So of course I started perusing google to see if anyone else has this problem, and I ran into all sorts of suggestions that might help. I tried using different USB ports, both display ports, I tried updating all drivers I could think of, and at one point even reinstalled my windows 10 from a completely clean SSD, followed by more reinstalling of most recent drivers for everything, but the problem of Oculus not recognizing my display port cable for anything more than 5 seconds persists.

And that's the weird thing: when I insert the DP cable, the icon turns green for about 5 seconds, after which it goes off again and Oculus tellms that there's no DP connection.

So it DOES see something. And the USB connection is flawless. It detects the cable in both DP ports, but in both cases switches off again after about 5 seconds.

I even tried reverting the version of the Oculus firmware to 2.1.1, as well as reverting NVidia software to a previous version. Nothing works.. not even for a bit!

Here are some hypotheses of what I think COULD be the case:

- Power supply doesn't provide quite enough power for the GPU. It works flawlessly in games and all that. but maybe the DP port needs to provide too much power to the Rift S. So when you plug in the cable, it's enough for it to detect the cable going in, but not enough to sustain the connection. This would have to be case for gazillions of other people with different GPU's and different PC configurations though,m since many people have the same problem.

- The faulty HDMI cable fried something in the GPU which now results in the DP not functioning properly. However, with the new HDMI cable the GPU works flawlessly, and it would have to have affected both DP ports equally.

- Something could be wrong with the Rift S or it's cable. I've tried reseating the connector that goes into the Rift S, and made sure it went in as far as it goes. I tried to find any dents or cable breakage, but everything looks fine and should work.

I'm going to try and see what happens when I use a different video card, but I have to borrow it from someone. If that doesn't work, I'm going to try and see what happens if I supply the GPU with power from a different PSU. I'll also try and see if I can get the Rift S to work on a different PC.

Looking through these forums and other sources though, it becomes clear that many many people are dealing with this same issue. Oculus seems to acknowledge that something is wrong somewhere between the software and the Rift S, but it hasn't become clear what it could be yet. They do say that they're looking into it, but haven't been open on what their progress is or what their findings so far are. Instead they provide people with a standard list of things to do, such as trying different USB ports, reinstalling software, drivers, etc etc. It has become clear that no PC configuration is exempt from these problems. In fact the only common denominator is the Rift S and the Oculus software, as far as I can see. 

It's been a very frustrating experience. One day everything works perfectly, the next day it's all gone without a hint of how to make it work again.

I've been a pretty vocal advocate of VR in general and the Rift S specifically, but now I'm afraid I have to advise people against it. It could be that all Rift S users are sitting on a time bomb!

Anyway here' hoping for the best. If anyone has the golden tip on how to solve this, I'd love to find out! Keep in mind I've tried all the standard stuff already though!

Cheers,

Peter
53 REPLIES 53

BoneDaddy1956
Level 2
I have the EXACT SAME problem!!!
I received the Rift S on 1/25/20.
Have NEVER been able to get it to work.
My PC was a 4 year old i7, 12 GB RAM, GTX1060 card.
Had that exact problem.
Put in a new USB3 card and got the USB to initialize properly, but then the DP would connect and drop 5 seconds later.
(And this was on a completely fresh Win 10 install with full updates to everything)

Thinking it was the age of my hardware, I built a brand new PC last week.
ASRock B450 Pro Mbrd, Ryzen 5, 16 GB RAM, M2 SSE, GTX1660.
I loaded the Oculus SW and it wouldn't work with the USB3 port on the motherboard.
Tried several USB3 ports on the back, and the DP connection kept initializing and dropping off.
Even tried the USB 3.1 port, which connected the DP slightly longer, but dropped off in10 to 15 seconds.
Nothing else plugged into the USB ports (other than mouse and keyboard).

I then tried it with the front panel USB 3, which got the DP connection to detect properly.
I advanced to the sensors calibration and it never worked....
Went back and uninstalled/removed everything & did a power off reboot.

This time, I tried it again with the front panel USB3 and the DP connection connected.
Instead of going straight to the Sensors calibration, I left it and waited for a bit....
After about 60 to 90 seconds, the DP connection dropped again.

EVERYTHING IS BRAND NEW AND I HAVEN'T GOTTEN THE RIFT TO WORK PROPERLY ONCE.....

I've been doing everything that support has asked me to.
Now, I am waiting - they are supposed to get back to me to see what they want me to do next.

I HAVE HAD THIS UNIT FOR OVER ONE MONTH NOW AND STILL HAVEN'T GOTTEN IT TO WORK

Sorry about the shouting....

Let me know if you have any luck, and I will keep you updated likewise.

Randy


danc77
Level 2
I have been having the exact same problems since late january, can someone please help?
P.S. i used to have the previous oculus rift and it worked flawlessly so i don't think it is my pc.

dan_m_griffiths
Level 3
Exact same problem here. Had the rift S on 13 May 2020.  Now a few days later after firmware updated to 2.2, it will not detect my display port.  Sent off a ticket, and logs, but still waiting for a reply.

wnstnwnstn05
Level 2
exactly the same problem is happening to me..

TK_Prince
Level 4
Same

DjYawe
Level 2
exactly the same problem here as well. ugh!

Kteeto
Level 2
I just had a new Rift S sent to me because logs showed my old rift s had problems with having black screens ( i did all of the solutions they gave me and from what i have tried online non have worked ) I got my new set and i got the display port issue now... i recently built my pc because back then on my first Rift S i had a prebuilt Asus rog g20, so i know for a fact that it wasnt my pc. Brand new Rift S straight out of the box and it doesnt read my display port for shit, I even updated my drivers and firmware for my GPU (GTX 1050 TI 4GB XLR8 by PNY) So lets see what will happen, I have alot of USB ports and i will switch to every one of them and see if it even fixes it, i read that it can be a misleading error and its usually the USB but ima see if its true.

inigo_armendari
Level 2
Exactly the same story here. Constant DP disconnections. Struggling with Oculus since March... I already purchased a new computer and performed all troubleshooting available, but no luck. It is clearly an Oculus hardware/firmware problem. Many users report that downgrading the FW would solve many issues, but I don't wish to perform such potentially risky step. My Rift S is failing in 3 different computers.

Honosuseri
Level 4


Exactly the same story here. Constant DP disconnections. Struggling with Oculus since March... I already purchased a new computer and performed all troubleshooting available, but no luck. It is clearly an Oculus hardware/firmware problem. Many users report that downgrading the FW would solve many issues, but I don't wish to perform such potentially risky step. My Rift S is failing in 3 different computers.


Rolling back the Firmware and the software is not a guaranteed fix. Even if it works it's not really a fix just a workaround, you need to block the Oculus Software from updating and then that has a knock on effect to downloading from the Oculus store.

I have had the Rift S for 6-7 months it's worked fine until just over a week ago. I've started a support ticket and done their suggested troubleshooting tips. The logs state it's an issue with USB not the DP! My USB drivers have not changed, there is no issue with the ports and the HMD has run off them fine since day one. So it's either a Software issue or my headset is faulty.

I've not heard any more from Oculus support in over a week. I shall give them a month from reporting the issue, if it's not resolved I'll contact the etailer I purchased from and have it returned. I'll look to replace it with the HP reverb G2 headset instead.