cancel
Showing results for 
Search instead for 
Did you mean: 

Rift S owners who had the Displayport issue and FIXED it: How?

pardalis
Level 3
Picked up a Rift S recently and it refuses to work because of the well-known displayport issue. I've already submitted a ticket, but I thought I'd try to gather info from the community as to which fixes worked and which didn't.

The specific issue I'm talking about is where after connecting the Rift S, both connections will seem OK for a few seconds, but then the Displayport disconnects and you're left with one of these status screens in the Oculus app:
hrwcjnbek1g2.pngy07o9desfx64.png
There's plenty of speculation as to the cause of this issue and no official word from Oculus as far as my research goes, the most likely culprits seem to be a power delivery issue where the headset is drawing too much power for the USB port to keep up (which, for some reason, causes an issue with the DP connection rather than the USB one), a bad cable, or a software/firmware issue caused by the 2019 update that brought Facebook integration to the Oculus app (this is, again, pure speculation, but there are a few articles that suggest these issues became more prevalent when that update dropped)

The behavior is the same for every "plug-in procedure" as Oculus describes it: Connect the USB3 cable, wait 10 seconds (the LED between the lenses goes from off, to amber, to white, and stays there- nothing from the displays themselves), connect Displayport. 

Here's everything I've tried so far, collected from forums and other sources:
  • Rebooting
  • Reinstalling Oculus app
  • Disabling power-management USB suspend options
  • Disabling USB suspend on USB devices through Device Manager
  • Updating video drivers
  • Reinstalling video drivers
  • Reinstalling video drivers using DDU and Safe Mode to fully wipe the previous driver
  • Running C:\Program Files\Oculus\Support\oculus-drivers\oculus-driver.exe , which starts silently and doesn't pop up any kind of status window, which seems like a bad way to design software but whatever
  • Connecting the headset through every available USB 3.0 and USB 3.1 port on my computer, using the proper "plug-in procedure" each time
  • Connecting a single monitor through HDMI rather than Displayport or DVI
  • Disconnecting all other non-essential USB devices
  • Checking the seating of the connectors on both the computer side and headset side
  • Checking the integrity of the cable, connectors, and headset, for kinks/frays/etc
  • Unplugging audio devices from the headset

Here's what I've seen online, but haven't been able to try yet:
  • Using a dedicated, powered PCI-E USB 3.0 card, specifically the Inateck KT4001 as (apparently) recommended by oculus support 
  • Using the above card but with different drivers (the ones that come with it, the ones Windows installs automatically, whatever "Fresco" drivers are, etc)
  • Using a powered USB 3.0 hub
  • Replacing the cable
  • Replacing the GPU
  • Replacing the entire headset
  • Replacing the entire computer

The fixes I haven't been able to try seem hit-or-miss, though the PCI-E card seems to have worked for some.

So here's my question to you, Rift S user who's fixed this issue: What did you do? What has worked out for you? If your headset worked and then suddenly didn't, do you remember around what time it happened or what you did around that time?

If your answer is "I stopped using a cable extender" or "I stopped using a mini-DP to DP converter" or whatever else, that answer doesn't apply to this issue. This issue is specific to the Rift S in its intended setup, with no dongles or adapters involved.

Once again i've already submitted a ticket and am working through the issue personally, this isn't me asking for solutions, it's me asking for experiences from people who had this issue and got it fixed.
27 REPLIES 27

rickenn
Level 2
For anyone out there still looking for a fix, this happened yesterday for me, and I spent 6 entire hours looking at fixes that never worked, until I finally found the issue.

SOLUTION
Opening the Oculus App, go to Settings > Beta > Opt in for Public Test Channel. After that, with only the USB plugged in, go to device manager, go to USB, click uninstall on Rift S. Then, unplug the USB. Next, go to the oculus app and in Devices, remove the Rift S device. After that, Add Headset, Rift S, plug in both cables. The DisplayPort will probably still say its inactive. However, you will now be able to update the firmware, and it should allow the DisplayPort to show as active.

Trust me, I went through almost a hundred solutions, even going as far as to replace entire computer parts and having no luck.

PS: If you're using third-party connectors, it can mess with the device, so avoid those if possible. For me, it was an extension cable.

I tried the tip with the beta from rickenn and thereby finally gave my Rift S the death blow.
After installing the beta drivers, even the USB cable is not recognized and the glasses are finally dead.

 

Thank you Oculus for these fantastic drivers, after more than a year of frustration I am finally free of this plague called Rift S. In the 17 months, not even 20 hours of playtime without disconnections, constant cable plugging in and unplugging or other problems were possible.

TheTaff-Dj
Level 3

Have tried everything, sent a log over at 04:24 last night (morning) as have had a a brick since xmas. Really really disappointed as up to the issues it has been an excellent unit....... 

Kind regards TheTaff_DJ

geraint.atkins
Level 4

For your info re USB and DisplayPort problems, i've had about a ticket raised with oculus support since december 2020.

 

today i got sent a brand new optical cable and it's fixed all my issues (for now, touch wood).

 

The ONLY thing that's different is i had an original rift s headset (brand new), a refurb unit sent as a replacement, and a brand new cable sent.

 

the cables that came with my headsets had similar serial numbers; Serial number: 1WEGCH507X0376 / 1WEGCH50L30346

 

the brand new cable out of box today has; 1WEGCH609E0303 and my mate who's never had a problem with rift s, his cable also begins with 1WEGCH6. 

 

check the QR code sticker on the optical cable and double check, my only guess albeit not confirmed is potential faulty batches of cables?

Hi G, you are a legend, thanks for taking time to respond. Just checked my SN and it is:-  1WEGCH51U99331 So seems to be in the same as in the "5" after the CH so probably the same batch as yours!  Still waiting on support to come back after sending log files over, but may send over your post and see what they think.

Kind regards TheTaff_DJ

geraint.atkins
Level 4

Feel free to quote my suppor ticket ref; 2188581

 

like i said it's not confirmed at the moment but the more people who confirm back 1WEGCH5 cables are being used and having problems the more this will get looked at from Oculus.

Cheers pal, just onto support through chat so will let you know how it goes.

Kind regards TheTaff_DJ

Another thing worth doing if you get a new cable;

 

Remove Potential Corrupt USB drivers

 

Especially if you've transitioned between general release and public beta channel.

 

programs and features - uninstall oculus.

 

I indexed my entire C:/Windows folder, app data, local, roaming, local low. etc and deleted all reference to oculus after uninstalling the software. - recommend doing this only if you've got a ssd or m.2 drive.

 

to do this on windows press windows key and type search - select "search permissions & history"

 

go down to excluded folders - click on windows, etc and remove them from exclusions.

 

go to file explorer and search for "oculus" and delete it all.

 

Ran a disk clean-up

 

Rebooted my machine.

 

Downloaded brand new copy of software from website and ran through entire setup process.

 

as a just incase also!

 

How did you get on

Hi G,

Passed on all the information to the support agent (who was actually really helpful), and the upshot is that they sent me DHL labels to send the headset and lead back to them and they are replacing them with a new set, so happy days! I should have these by next Friday so will be back up and running.

 

Really appreciate your help mate, don't think I would have got it resolved without it.

 

Cheers The Taff 

Kind regards TheTaff_DJ