cancel
Showing results for 
Search instead for 
Did you mean: 

Rift S owners who had the Displayport issue and FIXED it: How?

pardalis
Level 3
Picked up a Rift S recently and it refuses to work because of the well-known displayport issue. I've already submitted a ticket, but I thought I'd try to gather info from the community as to which fixes worked and which didn't.

The specific issue I'm talking about is where after connecting the Rift S, both connections will seem OK for a few seconds, but then the Displayport disconnects and you're left with one of these status screens in the Oculus app:
hrwcjnbek1g2.pngy07o9desfx64.png
There's plenty of speculation as to the cause of this issue and no official word from Oculus as far as my research goes, the most likely culprits seem to be a power delivery issue where the headset is drawing too much power for the USB port to keep up (which, for some reason, causes an issue with the DP connection rather than the USB one), a bad cable, or a software/firmware issue caused by the 2019 update that brought Facebook integration to the Oculus app (this is, again, pure speculation, but there are a few articles that suggest these issues became more prevalent when that update dropped)

The behavior is the same for every "plug-in procedure" as Oculus describes it: Connect the USB3 cable, wait 10 seconds (the LED between the lenses goes from off, to amber, to white, and stays there- nothing from the displays themselves), connect Displayport. 

Here's everything I've tried so far, collected from forums and other sources:
  • Rebooting
  • Reinstalling Oculus app
  • Disabling power-management USB suspend options
  • Disabling USB suspend on USB devices through Device Manager
  • Updating video drivers
  • Reinstalling video drivers
  • Reinstalling video drivers using DDU and Safe Mode to fully wipe the previous driver
  • Running C:\Program Files\Oculus\Support\oculus-drivers\oculus-driver.exe , which starts silently and doesn't pop up any kind of status window, which seems like a bad way to design software but whatever
  • Connecting the headset through every available USB 3.0 and USB 3.1 port on my computer, using the proper "plug-in procedure" each time
  • Connecting a single monitor through HDMI rather than Displayport or DVI
  • Disconnecting all other non-essential USB devices
  • Checking the seating of the connectors on both the computer side and headset side
  • Checking the integrity of the cable, connectors, and headset, for kinks/frays/etc
  • Unplugging audio devices from the headset

Here's what I've seen online, but haven't been able to try yet:
  • Using a dedicated, powered PCI-E USB 3.0 card, specifically the Inateck KT4001 as (apparently) recommended by oculus support 
  • Using the above card but with different drivers (the ones that come with it, the ones Windows installs automatically, whatever "Fresco" drivers are, etc)
  • Using a powered USB 3.0 hub
  • Replacing the cable
  • Replacing the GPU
  • Replacing the entire headset
  • Replacing the entire computer

The fixes I haven't been able to try seem hit-or-miss, though the PCI-E card seems to have worked for some.

So here's my question to you, Rift S user who's fixed this issue: What did you do? What has worked out for you? If your headset worked and then suddenly didn't, do you remember around what time it happened or what you did around that time?

If your answer is "I stopped using a cable extender" or "I stopped using a mini-DP to DP converter" or whatever else, that answer doesn't apply to this issue. This issue is specific to the Rift S in its intended setup, with no dongles or adapters involved.

Once again i've already submitted a ticket and am working through the issue personally, this isn't me asking for solutions, it's me asking for experiences from people who had this issue and got it fixed.
45 REPLIES 45

For all of you in this thread I have suffered your problem for so long. Since September 2020, to be exact, I've had not one, not two, but three (yes 3) refurb units sent to fix my issues. I've tried all of the above and more. 

The first issue arose when the Rift S was 4 months old. The touch controllers lost tracking and the background view vanished in the headset. Three weeks later and much stress of explaining myself over and over to Oculus support they agreed to issue a refurb replacement for the headset. Another three weeks later I eventually get the RMA labels. 

1st replacement arrives end October 2020. Worked okay for about two weeks then resorted to black screen after a firmware update. Unable to return from this despite having a spare cable to switch between.

2nd refurb sent in January 2021.  DoA.

3rd refurb sent mid February. Again DoA - black screen after immediate FW update.

Now at this stage, as you can imagine, I was naturally raging about it. The Rift S was virtually about to be launched into reality, across the trees, behind my garden. I did calm down eventually and no harm came to the device you'll be glad to read. After a bit of careful thought /logic I figured the root of the problem. The solution was surprisingly simple in the end. A solution that should work for everyone here. 

Buy a powered USB hub! One that comes with its own mains adapter.  I bought an Orico 7 port powered 3.0 hub on ebay.  I did buy a dedicated USB PCI card previously but that was absolutely useless with regards to the Rift S. Don't waste your money on a card if that's it's intended purpose.

As soon as I connected the hub to the motherboard USB the Rift USB plug was connected to it and you know what? The headset burst into life for the first time in 6 months and works like a dream since.

What this means is the Rift S USB connection is demanding more power than most motherboards can deliver.  The hub, being powered separately, can easily meet the demand of the headset.  My rig is not the latest tech (Ryzen 7 1700x/16Gb ddr4/MSI X370 pro/H115i/GTX 1070 super) and I have read countless forum posts from users with higher spec machines suffering the same problem. So get a powered 3.0 hub. Not expensive and will let you get back to VR gaming in no time 🙂

 

 

TheTaff-Dj
Level 3

Hi mate, 

I had the same issues and tried everything suggested including a powered USB3 hub as poster below suggests. It did not work for me so a waste of money really. I raised the ticket, pasted all the details, and logs that I had tried EVERYTHING they had suggested, then got shipping labels in 2 days, sent back and got replacement (refurbed but in great condition) in 5 days.....Plugged it in, worked straight away and I have had no issues since. so big up to Geraint, who without he sussing the SN as the issue I would still be stuck with brick!  Do your self a favour and don't bother wasting money on a USB hub!  

 

The only thing that worked was the help I got from Geraint Atkins   and this post:

 

Display port fix.png

 

 

Kind regards TheTaff_DJ

Hi mate, thanks for the post I appreciate the help. I had already tried the hub fix which did not work. See my reply above as to what the actual issue is and how to get it sorted.

 

Cheers TheTaff

Kind regards TheTaff_DJ

Thanks for the update on your situation but, trust me, the powered hub may be the only solution for a lot of folks.  Getting a refurb doesn't mean you get it working again. I had to endure 6 months of no VR whilst oculus sent three concurrent replacements.  The first refurb worked for two weeks then black screened after a FW update and all symptoms the OP described and illustrated with the DP/USB intermittent fault.  The second and third (current unit) were both dead on arrival and simply refused to kick into life. That's when I got the powered hub and my problem went away permanently. If you had no joy on the powered hub then you had a genuinely faulty headset I guess. You are one of the lucky ones.  The USB hub provides the power demand of the headset but it seems my motherboard can't deliver. I know a few people with VR and they report similar findings, with some saying the headset picks up on one m/b port only and no other. Oculus' nonsense triage flow is poor when it comes to troubleshooting. It only serves to destroy souls and make you spend countless hours you'll never get back doing stuff that will never fix it. Three weeks later, when you're a quivering shadow of yourself, they'll decide to do an RMA swap

😂🤣You are right about the quivering shadow of yourself, I did visit that dark old place before it got sorted!! And yeah, maybe I was a bit lucky and have a working unit again, but either way this issue is affecting 100's and possibly way more than that and the lack of action, help or guidance from such a big company is a disgrace.  The tin foil on my head say's its to drive sales to the Quest by intentional obsolescence (like Apple), obviously this would only happen in minecraft............

Kind regards TheTaff_DJ

They are not the easiest to deal with for support. Once the initial ticket is in the system, I was reduced to death by email trails for 2-3 weeks at a time.  In all cases, even after they agreed to replace it, it took 1-2 weeks for the RMA label to be emailed.  I mean how long does it take to generate a label and send it?  My next headset will be the new HP G2 offering. Facebook have ruined Oculus for me.

Kklou
Level 3

i have oq2 mine stopped working compleatly july10th 2021andstillnothing just peo:le takingaccounts and softwear didnt think people actually took softwear oq2/xbox1/nintendoswitch/laptop top and facebook acount al his happened thenwas locked out soon asi logged in fbwith oculus and not 1 developer has actually adressed me oe whats going o so of courzei startwd msking noise andstil nothing bt rheir workinon glasses tho

steve_40
Level 4

My Rift S display failed mid-game after 5 months of regular use. Display suddenly turned to snow for 2 seconds and then went black. After that, I got the perpetual "no DisplayPort connection" error.

 

I requested an RMA on 17th July 2021 and received my first reply from Oculus 11 hours later (this was on a weekend btw). I patiently followed through with all the requested troubleshooting procedures (4 emails from 2 different support staff), and received an RMA label on 20th July, so the process took only 4 days for me.

 

I shipped the headset on 21st July and I got a message from Oculus on Monday 26th July that the headset has been received, so I'm anticipating that a refurbished headset will be shipped out around the end of this week.

 

Edit: It's now been over been 3 weeks since Oculus received my RMA'd headset. Still waiting for them to ship a replacement back to me. I re-opened my support ticket and I was told there is no stock available to send back to me and I have to wait another 4 weeks. I will wait a couple more weeks then demand a full refund if I don't get a replacement.

OcuBrett
Level 3

 For my laptop I have to use the optical port adapter. I've been using my Rift S for years with various issues I've been able to resolve, but suddenly it would not recognize the optical port. I tried to reinstall the headset multiple times, and it just didn't recognize the optical. I bought this and problem solved:

https://www.amazon.com/gp/product/B07G26KJB6/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1

 

The optical now plugs into a different port, and all is good. I also bought that powered USB hub, which I haven't opened. I was going to try that next but may keep or return it.

steve_40
Level 4

Well I've finally got an email from Oculus that my refurbished headset is being shipped back. I'll keep you posted when I receive it in a few days.