Showing results for 
Search instead for 
Did you mean: 

Rift S owners who had the Displayport issue and FIXED it: How?

Level 3
Picked up a Rift S recently and it refuses to work because of the well-known displayport issue. I've already submitted a ticket, but I thought I'd try to gather info from the community as to which fixes worked and which didn't.

The specific issue I'm talking about is where after connecting the Rift S, both connections will seem OK for a few seconds, but then the Displayport disconnects and you're left with one of these status screens in the Oculus app:
There's plenty of speculation as to the cause of this issue and no official word from Oculus as far as my research goes, the most likely culprits seem to be a power delivery issue where the headset is drawing too much power for the USB port to keep up (which, for some reason, causes an issue with the DP connection rather than the USB one), a bad cable, or a software/firmware issue caused by the 2019 update that brought Facebook integration to the Oculus app (this is, again, pure speculation, but there are a few articles that suggest these issues became more prevalent when that update dropped)

The behavior is the same for every "plug-in procedure" as Oculus describes it: Connect the USB3 cable, wait 10 seconds (the LED between the lenses goes from off, to amber, to white, and stays there- nothing from the displays themselves), connect Displayport. 

Here's everything I've tried so far, collected from forums and other sources:
  • Rebooting
  • Reinstalling Oculus app
  • Disabling power-management USB suspend options
  • Disabling USB suspend on USB devices through Device Manager
  • Updating video drivers
  • Reinstalling video drivers
  • Reinstalling video drivers using DDU and Safe Mode to fully wipe the previous driver
  • Running C:\Program Files\Oculus\Support\oculus-drivers\oculus-driver.exe , which starts silently and doesn't pop up any kind of status window, which seems like a bad way to design software but whatever
  • Connecting the headset through every available USB 3.0 and USB 3.1 port on my computer, using the proper "plug-in procedure" each time
  • Connecting a single monitor through HDMI rather than Displayport or DVI
  • Disconnecting all other non-essential USB devices
  • Checking the seating of the connectors on both the computer side and headset side
  • Checking the integrity of the cable, connectors, and headset, for kinks/frays/etc
  • Unplugging audio devices from the headset

Here's what I've seen online, but haven't been able to try yet:
  • Using a dedicated, powered PCI-E USB 3.0 card, specifically the Inateck KT4001 as (apparently) recommended by oculus support 
  • Using the above card but with different drivers (the ones that come with it, the ones Windows installs automatically, whatever "Fresco" drivers are, etc)
  • Using a powered USB 3.0 hub
  • Replacing the cable
  • Replacing the GPU
  • Replacing the entire headset
  • Replacing the entire computer

The fixes I haven't been able to try seem hit-or-miss, though the PCI-E card seems to have worked for some.

So here's my question to you, Rift S user who's fixed this issue: What did you do? What has worked out for you? If your headset worked and then suddenly didn't, do you remember around what time it happened or what you did around that time?

If your answer is "I stopped using a cable extender" or "I stopped using a mini-DP to DP converter" or whatever else, that answer doesn't apply to this issue. This issue is specific to the Rift S in its intended setup, with no dongles or adapters involved.

Once again i've already submitted a ticket and am working through the issue personally, this isn't me asking for solutions, it's me asking for experiences from people who had this issue and got it fixed.

Level 4

My "refurbished" replacement Rift S headset arrived today, after 5 weeks since I RMA'd it back to Oculus. It was marked as "refurbished" on the box, but it appears to be pristine brand new 😁. Better still, it is WORKING 😁😁😁. So in my case at least, the problem with my old headset was clearly a hardware fault, something must have burned out after 5 months of frequent usage.

Oh that's very interesting.

My SN is an H5 as well on the headset cable and also broken, thing is though it's out of warranty and support is refusing to do anything about it.

It looks like it's not to unreasonable that there was a defect or a bad batch and now Oculus is covering their tracks.


Disgusting behavior imo.

Level 2

I checked back on this thread like I've been doing for weeks now trying to get the headset to work. I also have a 1WEGCH5OR20422 cable, and unending pseudo-DisplayPort problems. Just recently got a powered USB hub (Sabrent 4 port model) and still have fake DisplayPort problems and a fake 'On' white light inside the headset which just hides the fact that when you look inside the display is off.


As an added piece of information, sometimes when I would start the headset and get it to work by sheer random chance (months ago) I would see snow starting to form in the goggles. The snow would continually get worse and worse until the screen shuts off unless I put my hand up on the headset-side part of the cable and push or pull a little bit. Usually pushing up on the cable, which makes the snow vanish. Strangely, letting go of the cable then would not make the snow immediately come back, and everything would be crystal clear for a while. Only getting the cable twisted in strange ways would make the snow come back and you could usually just fiddle with it again to push the snow back. This is one case for the WEGCH5 cables having a high failure rate. I think mine is just beyond ever showing any snow anymore.


Sometimes I could get it to work by screwing with the Oculus software. Restarts, re-installs, punching the "Device Setup" button, turning beta on and off. On a few occasions, the "Headset audio does not work" error would be really good because it would mean the displayport problem would never happen that attempt. I usually give VR about 5-10 tries whenever I remember it, and it's not been behaving lately. Will hit support soon.

Agreed mate. It took me 6 months to eventually (third time the charm on RMAs) get a working unit from them back in February. Good news is I have a cable going spare should the current one pack in but the powered usb hub definitely keeps mine going. I tried it again the other day, without the hub and got the same age old symptoms as in the OP, so it is the solution in my case. Sometimes to stop intermittent Display port errors I only have to unlug/reconnect the USB part of the cable and all works fine again. I also observed the powered hub needs to be seen by the PC before I connect the rift to it.

Best to see if you can order a new cable for it. I did get similar symptoms, with the snow effect you experienced, when mine was RMA replaced the first time. I got 2 weeks temperamental use out of it before it stated going snowy then packed in completely, then I got another failed RMA replacement, before finally getting a third.  Even that failed but that was when I  had a brainfart and got hold of a powered USB hub. That fixed it in my case but doesn't seem to work for everyone.  Given there's a trend on the WEGCH5 cables failing I would suggest trying to get another cable online. 

Level 2

Hello everyone, I've been checking this forum for over a month trying to troubleshoot my VR with no success up until now. Spoiler alert, what fixed my issue was replacing the cable, since the SN had the H5 on my cable as someone pointed out previously, however, I don't think this is necessarily the case for everyone who's trying fix the issue since it depends on the circumstance you're on. I tried fixing the displayport issue with a USB powered hub and it obviously didn't work, but I did notice something reading this forum and other sources about this solution that no one has made a mention of and I'll explain it below.

USB powered hub solution: This usually ONLY works for people who've had their headset for the first time and doesn't work right off the bad. The theory is that the motherboard is potentially not drawing enough power to the headset since it seems to be a little picky in that sense. It could also apply to people who've only had a few days playing with it, but it could be less likely since your motherboard did the job in drawing enough power for the first days or at least that is my theory.

Replacing the cable: This is the most expensive paid solution to fixing the displayport issue, however, this can be the definite solution for people who've played on their Rift s for months, which in my case I lasted around 10 months without any issues until the last days with it. It showed different symptoms throughout that last month, like black screens, the VR video losing connection and reconnecting again and lastly some weird white dots showing on my VR.


The way I replaced my cable wasn't through Oculus since they don't ship in my country so I bought a third party cable from Aliexpress whose brand is LONGON, costed me around 80 bucks, had solid reviews and it's been working perfectly fine ever since I've gotten the cable. In conclusion, this should help other people choose the right solution according to their circumstance, although this is just my theory and is probably not 100% accurate.

Hope this helps you out guys! 🙂

PS: For anyone who's had one of their controllers dead or reconnecting constantly right after fixing the display port issue try leaving the battery out for a whole day since it resets whatever the hell makes the controller work. This seems to happen to the controllers when they are left for a long time without being used apparently.

Level 4

You dont have to wait ten seconds. It works immediately.

My VR 3.1 slot makes no difference.

I thought a powered hub makes for a less-that-desirable connection. A guy told me it is better to plug in directly to the computer.

Level 4

Another problem is I get a "display port not detected" error. A USB hub wont fix that.