Showing results for 
Search instead for 
Did you mean: 

Rift S touch controllers flickering again

Level 4
For a day or two now, presumably since the latest update, my touch controllers have started flickering in-game, but not all the time. The Oculus menu is fine but as soon as Home loads, one or other of the touch controllers will start flickering and vibrating at a fairly constant rate. It usually seems to be the right controller but it sometimes switches to the left one. I haven't been able to work out what provokes it to switch over. When it flickers, the background is visible through the controller. I've tried new batteries and tried removing them for a few minutes. When I had this problem a couple of months ago I fixed it by opting into the beta channel but I guess the poor code has caught up with me. Opting in and out of the beta channel makes no difference, nor does a full uninstall/reinstall. Again, the oculus menu is fine and the hands are visible. It's only when Home (or almost any game - Google Earth VR is fine for some reason) loads that the problems become apparent.

I see I'm not totally alone but has anyone identified a solution?
149 REPLIES 149

Level 3

R-Rova said:

I got my VR to finally work today. I was about to play Alyx as my first VR experience and then my controllers start to flicker...
Great first experience..

I went into the Beta of the Oculus app and the flickering was gone for me.
This might help some people.

Level 2
anyone still having this issue?? and is there a fix for it yet?

Level 3
The Oculus app v19 delivered via Beta/"Public Test Channel" fixed the issue for me 

Level 4

dburne said:

Haven't Oculus acknowledged they are aware of the flickering issue and are working on a fix?
I myself am not having the problem with my Rift S but obviously several folks are.

Use the Beta opt in, guys. That fixed the problem.

Level 3
I wonder how long the testing takes before they make it mainstream?

Level 4
I have to say that I'm lucky, until today I had no such problems, except if I leave the controllers outside of my boundary area quite a while, they are like on standby (I think it's made on purpose, if I play a racing game, I don't use controllers almost at all, why they should be online all the time? Battery economy 🙂 ), than they take like 4/5 seconds to get online again once picked up.
But also people say that this problem suddenly appears after you used a Rift for a while, mine it is just new practically and I don't hide that I'm worried
  • VR Headset Oculus Rift S
  • CPU AMD 3.700x - GPU Asus ROG Strix 2080 Super - MB Asus ROG Strix X570 F-Gaming
  • RAM 32GB G.Skill 3.600mhz CL 16 - Storage 1TB NVMe M.2 2280 - 2TB SSD 3.0 - 3TB HDD
  • Cooler Dark Rock Pro 4 - PSU Corsair HX 1.000i Platinum Modular
  • Fans Hub DeepCool FH-10 - Case Cooler Master H500P Mesh Option
  • Airflow 2x240mm in, 4x120mm out, 2x135mm CPU, 3x85mm GPU, 2x35mm MB

Level 2
Having the same issue. Tried Half Life: Alyx earlier and the hands constantly flickering to the floor makes it impossible to play. Will try opting in to the Beta and report back...

[EDIT] Beta seems to have fixed it for now. Used to be a permanent issue while playing Beat Saber, but I just tested it and it seems to have gone away.

Level 2
Thanks to odu14ick. He saved my life because my occulust rift s was really close to the garbage can. You will have to scroll up if you want the link because somehow Occulus web site doesnt allow me to do it. Follow the instructions. Its giving you the old version of occulus. 
I got the same issue as all of you now its fixed. Of course the old version of occulus home does not detect my Version 3 USB but who cares? I can still enjoy!

Anyway is there any news from the devs? Like hey guys we are concerned by your issues we are working on it? 

Level 4
The fix is in the v19 beta. If you opt into beta releases, you'll get it automatically.

Level 3
The fix is to downgrade (instructions in page 3 I think) or upgrade to beta. As I hate beta, hopefully Oculus can announce when the beta makes it public so that I can upgrade again..