cancel
Showing results for 
Search instead for 
Did you mean: 

Rift s mic issue (Solved)

matthew_ang_31
Level 2
hey guys, regular rift s user here. If you’re like me, who suffered regular mic snaps while using the rift s, it’s your lucky day! I recently came out with a solution for that and it is surprisingly easy. First, you have to download an app called voicemod (totally free!). It will then allow you to gain access to a new default microphone. So what you have to do is then to list your rift s microphone as the input and output audio in the VOICEMOD app itself. Then, you will have to go to your sound settings (input, output audio settings) on your pc and change your default mic to the voicemod microphone. Afterwhich you may have to go to the oculus app and do the same - as in to change the default mic to the voicemod mic. 

Eg. For those playing VRchat, remember to switch your microphone in-game to the voicemod microphone!

Hope this helps!
13 REPLIES 13

dburne
Level 16

MPires said:

Hi Dburne can you give the indication of the mic you bought? thanks.


https://www.amazon.com/gp/product/B07D561S67/ref=ppx_yo_dt_b_asin_title_o06_s00?ie=UTF8&psc=1
Don

EVGA Z390 Dark MB | I9 9900k| EVGA 3090 FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case| Rift S | Quest |

Kazdi
Level 2
This doesnt change anything for me. Still crackling/metallic voice even when everything is setup through voicemod

Shundrie
Level 2

Fangzhou said:

 😐 I bought a $120 ModMic Wireless to solve the Rift S microphone problem last week.
Now I saw this thread


same . modmic didn't fix it 

Update, after changing many more settings, it appears to have fixed the problem. I'd love to tell you what I did but I just changed everything to ModMic including some settings in OBS. 

akibam
Level 2

For about a couple of months I had no problems with Rift S but one day suddenly, while using voice commands in X-Plane, the mic stopped working. Replugging cables, USB and Display Port did not help. Restarting did not help. I disconnected the PC from the mains for a few minutes and the problem seemed to be resolved but only for about half an hour. Changing USB port also helped for a few minutes. Then I tried disconnecting other mic devices from my PC and left the USB cable in the newly chosen port. I think this has solved the problem as everything is normal since I made those changes about a couple of hours back. I hope it helps others and myself as well forever.