cancel
Showing results for 
Search instead for 
Did you mean: 

Sensors can't track headset/Three dots of death - faulty/corrupted Rift S USB Hub driver?

Worset
Level 2

This is an issue I've struggled with for the better part of a couple of weeks now. This is an issue that many other users seem to have struggled with both recently and years past from now. This isn't even the first time I've encountered an issue like this. And without a doubt this is something that Oculus/Meta/whatever is already more than aware of. But I 'think' I've identified a root cause for this issue, it's just a matter of figuring out where to go from here.

 

Context/Symptoms - As I have already said, this issue arose a couple of weeks back. Went to don my headset, and the first thing I see is a black screen with three blinking dots in the middle of my line of sight. I can still hear the sound coming out of my headset though. Chances are, you already have an idea of what I'm talking about.

I went straight into the device setup for my Rift S device, thinking just a simple 'reset' would fix it. But then: 

 

image_2022-07-06_191101105.png

 

You can kind of guess where this is going.

 

After a lot of futilely attempting every basic workaround I could find online, eventually going into the Device Manager I noticed something. For the uninitiated, when your Rift S headset is in fully working order, your Device Manager should show two separate 'Rift S USB Hub' entities under the Universal Serial Bus section. But for me, it looks more like this:

 

Capture.PNG

 

(Also included the other USB devices here to give a better idea of what I'm working with - maybe something here is relevant?)

 

For the record, this shows up usually when I have the headset plugged in to the powered USB 3.0 hub I bought specifically to combat this issue. Otherwise, when plugged into the computer itself, sometimes only the single Rift S hub shows up, but not the second. Perhaps something to do with how much power the headset is receiving, which is apparently a possible factor? Which is the reason I got that powered hub to begin with, but I digress.

Anyway yes, I've tried every port, and yes, I've ensured that it is always a 3.0 (blue) port. Something else that might be worth noting is that the blue light on the front of the headset isn't turning on, as if the sensors aren't being activated whatsoever. 

 

So now that I've identified (or at least I think I have) that the issue 'might' be driver-related, I tried a load of other workarounds and solutions - which I will list further down - but none of them have yielded any positive results, which leads me here. This is my last ditch effort to fix this, and if this ends up going nowhere I'll most likely ditch this PoS entirely and find some other VR kit that will actually work - preferably not from Oculus/Meta. (Don't worry, all of my VR games are on Steam, so I will be losing literally nothing)

 

Attempted Solutions - Oh boy, this is probably gonna be so long that I'll likely miss something, but here goes nothing:

 

  • Plugged into every USB 3.0 port on my computer, I also tried a powered USB 3.0 hub which I bought believing this might be a power-related issue (This one specifically, since I had seen it recommended elsewhere: https://www.amazon.co.uk/atolla-SuperSpeed-Charging-Splitter-Individual/dp/B099MLL1FG/ref=sr_1_4?key... ) and tried every port on that. No dice. (Note: I mentioned above that sometimes the unknown USB device isn't present when the headset is plugged into the computer and not the hub, so it seems like the hub is doing something maybe?)
  • Uninstalled the working Rift S driver (and removed the driver software with it), the faulty one, and every USB port on my computer through the Device Manager. I've tried this both with and without Oculus running in the background, with and without my headset being plugged in. Sometimes the faulty one would stay gone for a while, until it inevitably came back, but I was still left with only one working Rift S USB Hub device, which isn't enough.
  • Checked the power management settings for every USB port, - 'allow computer to turn this device off' is unchecked for every single one - customised my computers' power plan to disable USB selective suspending, and set my computer itself to it's highest performance setting.
  • Uninstalled, reinstalled, repaired etc. the Oculus software itself. I also made sure I removed all the AppData and ProgramFIles Oculus folders every time I did - all that really did was make me have to sign into my accounts again.
  • Ran the 'oculus-drivers.exe' program - worked for resetting the drivers I had uninstalled, but not fixing the broken one. Again, tried it both with and without the headset plugged in.
  • Detaching and reattaching the headset end of the cable into the headset itself. Even tried cleaning out the ports just in case. (Side note: why would the headset not being plugged in properly be the issue if the computer can still detect the headset and send sound and video output TO the headset? The program on my computer must be creating and sending the three dots screen to the headset after all)
  • Tried another headset cable I had lying around - like I mentioned before, this isn't the first time I had an issue like this, and sending me a replacement cable did work, but if a replacement cable is only a temporary solution then I REALLY don't want to be sent another replacement for my current replacement, I want something a bit more permanent, or at least easily replicable. And I know attempting to use the original cable that my current one is replacing sounds like a stretch (and it probably is), but I was desperate at this point.
  • Turning on and off the beta channel in the oculus app. Downloaded the updates but nothing notable changed.
  • Reinstalled Windows 10 using the ISO on Microsoft's website - this way I could reinstall the drivers, updates, etc. without losing my apps and programs. This actually showed some promise initially, as the Rift S drivers (USB, audio etc.) actually did reinstall - but nothing changed or got fixed. Still couldn't pass the sensor check.
  • Tried rolling back the drivers and firmware using both of these methods: ( https://www.reddit.com/r/oculus/comments/llo2gk/google_drive_folder_of_various_oculus_pc_client/ ) & (https://www.reddit.com/r/oculus/comments/hnfhdx/psa_you_can_revert_oculus_drivers_to_fix/ ). The only change was that sometimes I would get a notification about setting an Oculus password because I was using a Facebook account or something silly like that. The failure rate for the headset connecting at all also got much higher. (To be fair, it does seem that this particular solution is intended to resolve issues regarding the display port which I never experienced, but eh, 'twas worth a try).
  • Checked for updates to my graphics card. I did have an update for a 'game-ready' driver which I installed but didn't do anything to rectify this specific problem.
  • Checked for updates to my AMD motherboard. Found a program on their website that installed a bunch of chipset drivers, but they didn't help either.
  • Checked camera permissions in the settings. Here's how it looks:

image_2022-07-06_192928753.png

 

What I Haven't Tried

  • A PCI-E card. I've already spent enough money trying to fix this issue, and my money situation is already difficult as is. Even then, I don't really have the knowledge or confidence to try and install components myself, and although this particular solution seems to work for most people, it has also been a dud for others. I'm not going through all that effort for something that might or might not work. I've already done that once with the powered hub.
  • A fresh, clean Windows install. Idk what this would accomplish that the ISO method didn't, and I don't really want to find out - I have a lot of important work-related s**t on my PC so I'm not taking any chances.
  • Testing the headset on someone else's PC - although technically speaking I have tried this one. My brother actually has the original Rift, and it actually works, so I figured I could try using my headset on his PC and see if anything changes. Unfortunately though, his PC only has HDMI ports and no Display Ports, so I couldn't do it. Maybe we have an adapter or something somewhere, or maybe I just missed it - I might come back to this one, and will update if anything comes of it.

Computer Specs (cause I know someone will inevitably ask about this) -

 

Motherboard: AMD Ryzen 5 3400G with Radeon Vega Graphics 3.70 GHz

16GB of RAM

GPU: NVIDIA GeForce GTX 1660

OS: Windows 10 Home

This machine is 100% VR-capable, I have without a doubt played VR titles on this machine with performance issues only arising if I have GeForce Experience screen-recording/instant replay enabled.

 

Maybe there's more, idk, I just mentioned everything I thought was relevant.

I have not made any modifications to this machine since I bought it, this is the hardware it came with.

 

And last but not least: Logs -

 

***EDITED MESSAGE TO REMOVE PII*** 

 

I think that about covers everything. I tried to be as thorough and comprehensive in this post as I possibly could because I just want to know once and for all if this is a problem that can actually be fixed or if I should just give up on Meta VR for good. I'm heavily leaning toward the latter atm, so consider this my last hope. 

 

- Worset

13 REPLIES 13

Hey again! We just wanted to check back in with you. If you still need assistance please select our name to get to our profile page, or click here. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message.

dr0neworld77
Level 2

Has anyone tried a adapter? DisplayPort to USB-C. My graphicscard has a USB-C, which means if there is something wrong with the DP, you could bypass it with the adapter. Anyone care to try this out, or has already?

Eager to hear the results.

does the adapter work for u? because i'm having this problem after last update i never had before

 

I don't have the adapter, I was only asking if someone else has tried this method and yielded good results. I might get it and try, but I am not sure it will work. It should theoretically work, since the USB-C has more power for the headset as well, I don't see why it can't be a win-win with the adapter.

I'll get back with a reply if this works for me.