cancel
Showing results for 
Search instead for 
Did you mean: 

V28 on Rift S makes virtual desktop all black

gigna1
Level 2

Rift S before update, no problem. After v28 update, can't use virtual desktop. it can still click but it's all black so I can't see what I'm clicking. Trying reinstall Oculus software to see if it fixes it or not.

1 ACCEPTED SOLUTION

Accepted Solutions

Boccaromel
Level 3

I have found a solution that works for me. Go to Windows 10 Configuration > Display > Graphics Settings > Graphics performance preference, choose "Desktop app" and click Browse. Select "C:\Program Files\Oculus\Support\oculus-runtime\OVRServer_x64.exe", click Options and choose "Power saving". Then restart "Oculus VR Runtime Service" (or restart the computer).

 

After some investigation, I concluded that, in hybrid graphics systems (for example, integrated Intel + discrete NVidia), the oculus dash desktop only works if the "OVRServer_x64.exe" process runs in the integrated graphics. Since v28 it seems that process runs by default in the discrete graphics. But you can override that. First I tried to make a profile in "NVidia Control Panel" to force Integrated graphics, but it didn't work. Then I discovered that, since Windows 10, it has it's own section "Graphics Settings" to override this that takes precedence over the NVidia Control Panel. More information on https://www.freemancw.com/2020/11/desktop-duplication-on-hybrid-graphics-systems/

View solution in original post

7 REPLIES 7

gigna1
Level 2

Repair did roll it back to v27 but the issue continues.

same problem here

 

 

 

OculusSupport
Oculus Community Manager
Oculus Community Manager

Hello @gigna1 & @JuicyJoshWasTaken  If you haven't already please open a support ticket with us here and we will be happy to assist you. Thanks!

Boccaromel
Level 3

Same here

Boccaromel
Level 3

Ticket open with Oculus, no useful response yet.

 

While i'm in the desktop option of the Oculus Dash, the OculusServiceLogs is constantly registering these entries in loop every few milliseconds:

30/04 18:09:01.430 {DEBUG} [Facedesk] Registering for window capture of HWND 0 (0) HMON 65537 (10001)
30/04 18:09:01.453 {DEBUG} [Facedesk:DXGIDC] GetShaderResource not ready, returning not visible
30/04 18:09:01.453 {!ERROR!} [Kernel:Error] OVR Error:
Code: -3000 -- ovrError_Initialize
System error: -2005270524 (887a0004) -- Este sistema no admite la interfaz de dispositivo o el nivel de característica especificados.
Description: Output duplication
OVRTime: 4362.454003
Time: 2021-04-30 18:09:01 [454:301:700]

30/04 18:09:01.453 {DEBUG} [Facedesk:DXGIDC] GetShaderResource not ready, returning not visible
30/04 18:09:01.453 {!ERROR!} [Facedesk:DXGIDC] OVR Error:
Code: -3000 -- ovrError_Initialize
System error: -2005270524 (887a0004) -- Este sistema no admite la interfaz de dispositivo o el nivel de característica especificados.
Description: Output duplication
OVRTime: 4362.454003
Time: 2021-04-30 18:09:01 [454:301:700]

There are multiple possible causes for error 0x887a0004 (DXGI_ERROR_UNSUPPORTED), being one of them trying to capture throug the discrete device instead of the integrated device: https://docs.microsoft.com/en-US/troubleshoot/windows-client/shell-experience/error-when-dda-capable...

imkindasleepy
Level 2

i have this same problem with my normal rift, i cannot see anything on my virtual desktop but i can interact with it still 😞

Boccaromel
Level 3

I have found a solution that works for me. Go to Windows 10 Configuration > Display > Graphics Settings > Graphics performance preference, choose "Desktop app" and click Browse. Select "C:\Program Files\Oculus\Support\oculus-runtime\OVRServer_x64.exe", click Options and choose "Power saving". Then restart "Oculus VR Runtime Service" (or restart the computer).

 

After some investigation, I concluded that, in hybrid graphics systems (for example, integrated Intel + discrete NVidia), the oculus dash desktop only works if the "OVRServer_x64.exe" process runs in the integrated graphics. Since v28 it seems that process runs by default in the discrete graphics. But you can override that. First I tried to make a profile in "NVidia Control Panel" to force Integrated graphics, but it didn't work. Then I discovered that, since Windows 10, it has it's own section "Graphics Settings" to override this that takes precedence over the NVidia Control Panel. More information on https://www.freemancw.com/2020/11/desktop-duplication-on-hybrid-graphics-systems/

View solution in original post