cancel
Showing results for 
Search instead for 
Did you mean: 

VR won't load. X Plane 11 - Rift S

1960Steve
Level 3
Click VR and it begins loading. Load screen reappears and then does nothing. Click DONE and the X11 crashes.

i5  32gig RAM  1080 card 
1 ACCEPTED SOLUTION

Accepted Solutions

kojack
Volunteer Moderator
Volunteer Moderator

1960Steve said:

What's Vulkan mode?



Vulkan is a newer rendering pipeline, it's an alternative to OpenGL. It's far more modern and can give better performance in games. But it requires a fair bit of effort to support, it's not an automatic thing, the developers need to rewrite their graphics engine.
In X-Plane 11.50 they added an optional Vulkan renderer. There's a checkbox to turn it on in the graphics settings page. It runs better and doesn't have the bug that stops X-Plane from running on Oculus runtime v17.
Author: Oculus Monitor,  Auto Oculus Touch,  Forum Dark Mode, Phantom Touch Remover,  X-Plane Fixer
Hardware: Threadripper 1950x, MSI Gaming Trio 2080TI, Asrock X399 Taich
Headsets: Wrap 1200VR, DK1, DK2, CV1, Rift-S, GearVR, Go, Quest, Quest 2, Reverb G2

View solution in original post

61 REPLIES 61

1960Steve
Level 3
Here is the LOG for that secrtion.
0:00:10.064 I/WIN: Showing subscreen Main Menu
0:00:10.064 I/OVR: User is entering the holodeck.
0:00:10.064 I/WIN: Opened window Primary V11 UI
0:00:16.491 I/WIN: Showing subscreen Settings
0:00:19.328 I/OVR: Initializing VR Subsystem.
0:00:57.505 E/OVR: Session display lost, becmoing a zombie.
0:00:57.511 E/VR_BRIDGE: Shutting down hardware because the VR HAL is now in a zombie state.
0:00:57.516 I/OVR: Shutting Down VR Subsystem.
0:03:54.484 I/OVR: User is leaving the holodeck.

TomCgcmfc
Level 16
Sorry but it's kinda hard to say (looks like a display port problem, but who knows?) since you do not give your PC specs, the version of xp11 you are using (v11.41 or 11.50b6 beta, your Oculus version (v16 or v17ptc), your nvidia driver version, and whether or not you have managed to run xp11 in vr before.

Just a wild guess of what to do but I would make sure your nvidia drivers are reasonable up to date (I'm using 442.19), your headset cable and pc connections are firmly connected (maybe unplug and plug them in again, maybe even try a different usb port and/or DP.

You could send your last xp11 logfile to Laminar and see if they can help sort this out.  Good luck mate.

Edit; Also, make sure that if you are using any super sampling to take this back to 1.0 to begin with.  If it is too high xp11 can often hang/shutdown when going into VR.  Also, make sure that your xp11 settings are not too high as well.  What you want to start off with is 2D xp11 settings that give you about 70-80fps on your monitor.
9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

1960Steve
Level 3
Thanks for that - a few things to try. It has been running fine for months and I can't work out what changed. 

1960Steve
Level 3
Repaired Oculus and this has fixed it... for now!  🙂

Bwall22
Level 2
Something really wrong with XP11.5 beta and Rift S. I have taken out all plugins and custom scenery from XP11 along with preferences and validated files in Steam. Repaired (and re-installed Oculus software) and RiftS does not want to work with Xplane 11.5x, or vice versa. I understand XP11 does not run via SteamVR like other headsets, rather via the Oculus software directly. Oculus and Laminar need to talk about this, one killed the other. I have submitted tickets to Laminar but I now going back to 11.41, 11.5x not ready from primetime, at least if your fly with an Rift S headset.

TomCgcmfc
Level 16
Works fine with my Rift cv1.  Maybe make sure you are not on an Oculus PTC update.  Also check your gpu driver is reasonably up to date.  The only issue I have is that it will not exit properly and I need to use task manager to kill it.  Been doing this since Oculus v13.

If xp11.41 works ok just stick with that until 11.50’gets out of beta, especially if you are using any xp11 plugins.
9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

dionicolas
Level 2
hi all.. had the same issue as above after update to 17.0 ...soon as i clicked on vr enable button... would freeze screen..
so i dl the oculus rift setup file and did the lengthy install.. after install i went to notifications and saw was dl  9 files to update to 17 ... i canceled the update so stayed on 16.0 and works  !!
then went to options to cancel auto dl and dl while in VR//.. gotta watch for the auto dl so it does not update again...good luck to all !..

Sandor_Black
Level 2
X-Plane 11 will not boot into VR mode since V17 was released.
Loads of X-plane 11 users affected. It won't let me post link here to the discusion forum on X-plave 11 forums.


JRE11
Level 2
Yes same issue....