Showing results for 
Search instead for 
Did you mean: 

new Rift s Giving error "Oculus isnt working correctly" after about 30 mins

Level 2
After about 30 mins of play i unplugged my new rift s only to plug it back in later and it to no longer work only giving  the error message stated above, i have tried to remedy this issue in a multitude of ways from resetting the viewport cable to updating drivers to updating windows reinstalling oculus app etc. but nothing has worked so far. Has anyone else had this issue or have any way they know to fix it? the rift s still says its connected and the white light pops on but no display shows when the headset is on

Level 3
Quite common problem. 99% of the time the issue is caused by the USB power saving. Try disabling it, if the problem is still there, download Oculus Tray Tool (OTT) and disable the power saving from there. Hope it works!

Walkaround to avoid to disconnect the USB: Go inside the oculus\support\oculus driver folder and run oculus-driver.exe. It will reinstall the drivers (give it 10 to 20 seconds) and run again oculus app.

Level 2
I tried to do both things and they didnt seem to help unfortunately, its possible that i'm doing the usb power issue wrong but i was still getting the same issue, thanks for the help anyways.

Level 2
in addition i seem to be getting some strange graphical glitches with  the oculus software, i get a loit of staticy pixels on it at strange times and it doesnt appear to be my monitor but also wasnt fixed via a fresh reinstall of the application.

Level 15
Sounds like a cable issue.  Maybe try reseating all your headset connectors (incl the one in your headset) and see if this helps. 

As far as usb power setting go you want to disable all your usb ports power saving options.  Just google ' disable usb power saving windows 10 ' to see how to do this.

Also, you can also google Oculus Rift S troublshooting for more tips.  Good luck mate.
9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro