cancel
Showing results for 
Search instead for 
Did you mean: 

v17 PTC PC Software Release Notes

ShowbizDonkey
Oculus Community Manager
Oculus Community Manager
Social Reporting

  • We’ve made improvements to in-VR reporting. These changes include:
    • Streamlined the reporting process.
    • Updated language around reasons for report.
    • Prevented reports from being submitted without evidence.
    • Improved clarity around when a report has been successfully submitted.

Oculus Link

  • General Stability improvements
54 REPLIES 54

Richooal
Level 12

TheWors3 said:

can you guys please allow quest to use the full color range while using link? blacks are grey and contrast is reduced, colors washed out...



If you want the real deal, buy a Rift. They cost a bit more than a cable though.

i5 6600k - GTX1060 - 8GB RAM - Rift CV1 + 3 Sensors - 1 minor problem
Dear Oculus, If it ain't broke, don't fix it, please.

TomCgcmfc
Level 15

blazeflre said:


MakGarett said:

Oculus Link
  • General Stability improvements
Link still doesn't work anymore for me after updating Oculus app. Still no V17 on Quest side for the moment hope it will start to work again.

Same here I haven't been able to play since april

Try to stay on the same Version (currently v16) and avoid Rift PTC.
9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, Q2 w/Air Link, Vive Pro

jab
Level 8


You're going to lose everyone if you keep making social updates only. A lot of people already lost faith in you.
Although for now, I'll pretend the lack of actual updates is due to coronavirus. After that, you better have something worth it for PC VR.


 The problem is that facebook looks at users as a commodity that they can exploit as they see fit for profits.This is marginally acceptable when you are using a free service like facebook.com, but DEFINITIVELY NOT OK when you purchase an actual product like your VR headset. Unless they plan to give away the headsets and games for free that is..

R-power
Level 2


This update causes my CV1 to report that it needs a USB3 connection despite being plugged into one.  Switched ports, got the green check mark for a solid connection, put the headset on and nothing happens.  Go back into the devices screen and it says "Poor tracking" when the screen is black and there's no audio.  Tried reseating the HDMI cable, plugging into every USB3 port on my system, nothing worked.  The only thing that fixed it was rolling back to v16.

I really hope you take this seriously and actually fix this before pushing it out to everyone as a release.  My headset has been a bundle of problems since December, with low overhead, constant stuttering that can only be fixed by a reboot, a complete inability to do any supersampling without stutters despite having an RTX 2080, and other nagging issues like pinned Dash windows being glitchy.  But at least on some level it still works.  If this update is pushed to release as is, my headset will be non-functional.

If you need any further information from me like logs or want to do some troubleshooting steps to try and figure out the issue feel free to contact me at the email associated with this account.  I'll happily help in any way I can if it means this software wont be released until the issue is fixed.



same for me.
cv1, 4years without a problems, i think more than 5000 hours in iracing....
since last update to beta neal apr.30th
yellow waring for usb2 on mask (?????) and 3 sec. black screen each 10 min working
pc, nvidia all updated

doing your suggestion,
stopped beta slider;
automatic roll back to v16
all green and no more black screen

i ask OCULUS STAFF to fix the issue on v17.
but no more beta by my side
i destroyed a 4 hours race at nurburgrng not for driving errors but for BLIND PERIODS driving.....
unbelievable

adam_poole_313
Level 7

R-power said:
cv1, 4years without a problems, i think more than 5000 hours in iracing....
since last update to beta neal apr.30th
yellow waring for usb2 on mask (?????) and 3 sec. black screen each 10 min working

i ask OCULUS STAFF to fix the issue on v17.




You better block Oculus through your firewall right now before the update becomes final and mandatory and then who knows how long you will have to wait for them to fix it. Plenty of times there have been complaints about broken PTCs and they just push them right through anyway.
Oculus Rift S, CV1
Intel i7-8700K
ASUS ROG Maximus X Hero
16GB DDR4 x 2
4 TB SDD, 2 TB SSD, 1 TB SSD
Windows 10 Home

Remmer_G
Level 5

yellow waring for usb2 on mask (?????) 
Same for me, but after switching back to 16 the problem remained. Eventually had to install a PCI USB 3 card I had and plug the headset USB into that, which solved the problem so far.

It really seems to me that their driver/firmware updates are somehow demanding more power than my USB ports can handle. Using a powered USB hub seemed to help last time, but now not enough. I don't know what's actually happening. But yeah, last Facebook product ever.

bloggdesk
Level 2
New one , This information is  very nice and useful to my every staff 
Thank You So Much

blanes
Level 8
Since about a week ago everytime I turn my PC on to do some Rift S simracing I have to unplug then replug my Rift S usb plug to get the software to recognise it. Otherwise it gives an error saying headset is not connected.  

So I unsubscribed from the Beta Test Channel and the older v16 Oculus software reinstalled but the problem remained.  Also now on every Steam Racing title I have I get an error message saying my Headset is not supported.  I only have to click Ok for the game to proceed and load correctly but all this is pretty annoying.

Has anyone from Oculus support acknowledged any of these issues to at least put our minds at rest that a fix is in the pipeline somewhere ?

Shooter80
Level 3

Remmer_G said:

had to install a PCI USB 3 card



Which model of USB 3.0 card did you install?

Digikid1
Level 12

Shooter80 said:


Remmer_G said:

had to install a PCI USB 3 card



Which model of USB 3.0 card did you install?



The ABSOLUTE BEST one is this one.