cancel
Showing results for 
Search instead for 
Did you mean: 

Upload failed - Build upload error

Lucashijman6
Level 3

I'm unable to upload the first release build of my game in Oculus Developer Hub. There's a generic error with no further user feedback on why and what I can do about it.

ODH unknown error.PNG

 

These are the steps I followed:

1. Download most recent version of ODH (2.7.0)
2. Correctly set up the manifest (as explained on https://developer.oculus.com/resources/publish-mobile-manifest/)
3. Create build of my game in the game engine I use (Godot).
4. Upload build in ODH (or via the OVR platform utility, see my reply on @TonyVT).

9 REPLIES 9

Lucashijman6
Level 3

Upon first trying in v2.7.1 the error changed. It's still not very helpful.

Lucashijman6_0-1662560914512.png

The log file it refers to is too big to show. I think this is the most relevant part:

2022-09-07T14:23:34.077Z [DEBUG] Run args: {"appId":6082539628428979,"apkPath":"C:\\Users\\Lucas Hijman\\Documents\\Afstuderen\\Publicatie\\Oculus App Lab\\2.1.1.apk","channel":"store","draft":false,"excludeAddons":false,"inheritAssetFiles":false,"isODH":true,"notes":"First public iteration of InaniBrutus for VR.","token":"(removed)","uploadConcurrency":null,"platform":"ANDROID_6DOF"}
2022-09-07T14:23:34.327Z [DEBUG] Server log: {"app_id":6082539628428979,"log_level":"DEBUG","event_name":"COMMAND_PARAMS","stack_trace":"at Object._log (C:\\snapshot\\D_Zfull-fbsource\\edenfs\\redirections\\arvr\\js\\temp\\build-ovr-platform-util\\lib\\ovr_platform_util.js)\nat Object.debug (C:\\snapshot\\D_Zfull-fbsource\\edenfs\\redirections\\arvr\\js\\temp\\build-ovr-platform-util\\lib\\ovr_platform_util.js)\nat C:\\snapshot\\D_Zfull-fbsource\\edenfs\\redirections\\arvr\\js\\temp\\build-ovr-platform-util\\lib\\ovr_platform_util.js\nat processTicksAndRejections (node:internal/process/task_queues:96:5)\nat async C:\\snapshot\\D_Zfull-fbsource\\edenfs\\redirections\\arvr\\js\\temp\\build-ovr-platform-util\\lib\\ovr_platform_util.js","extra":"{\"appId\":[MY_APP_ID],\"apkPath\":\"C:\\\\Users\\\\Lucas Hijman\\\\Documents\\\\Afstuderen\\\\Publicatie\\\\Oculus App Lab\\\\2.1.1.apk\",\"channel\":\"store\",\"draft\":false,\"excludeAddons\":false,\"inheritAssetFiles\":false,\"isODH\":true,\"notes\":\"First public iteration of InaniBrutus for VR.\",\"token\":\"(removed)\",\"uploadConcurrency\":null,\"platform\":\"ANDROID_6DOF\",\"os\":\"{\\\"platform\\\":\\\"win32\\\",\\\"arch\\\":\\\"x64\\\",\\\"type\\\":\\\"Windows_NT\\\"}\",\"cli_version\":\"1.76.0.000001\",\"compatibility_version\":2,\"app_id\":6082539628428979,\"session_id\":\"6082539628428979_2022-09-07T14:23:34.327Z\"}"}
2022-09-07T14:23:34.455Z [DEBUG]
Validating build...
2022-09-07T14:23:35.373Z [DEBUG] A server error occurred. The request will be retried.
2022-09-07T14:23:35.374Z [ERROR] Server log: {"app_id":6082539628428979,"log_level":"ERROR","event_name":"API_ERROR","stack_trace":"at Object._log

ItsDavidBrown
Level 3

same here, i don't know if this is some sort of issue on meta's end, but oh my god is it annoying.

Thanks for the reply. The event name API_ERROR in the log makes me indeed think it's on Meta's end.

issimissimo
Level 2

Same here

TonyVT
Level 4

Same here.I wonder what's happening

TonyVT
Level 4

Actually I've done the upload with the command line utility and it worked! So I suggest you do the same:

 

Oculus Platform Utility Reference | Oculus Developers

bpears
Level 3

I have the exact same issue even after trying 2.7.2

I also attempted that, but to no avail. Same error.Command line error.png

EDIT:

It worked using the hub installed on another computer. Hub 2.7.2. Weird thing is, Ive tried uninstalling and deleting app data of 'Oculus Developer Hub' and 'odh'. There must still be some conflicting remnant somewhere that is throwing the app off on my main computer.