cancel
Showing results for 
Search instead for 
Did you mean: 

How to disable the health and safety warning for development purposes in 1.3?

wbsk
Level 4
Is there a registry hack or similar since the option is no longer available in the settings panel it seems?
47 REPLIES 47

kondrak
Level 4
Currently there's no way to do this.

jimbo00000
Level 3
I'm happy to report the HSW no longer appears for me. I saw it every time the first day and found it slightly onerous, but now it seems to have disappeared. Maybe it goes away after a day?

In any case, I find the development process to be quite smooth now. Running a program from Visual Studio immediately switches from home to the "Please Wait area" for a quick 1-2 second fade, then into the program. Thank you, Oculus.

wbsk
Level 4
Every time I do a debug/run iteration from my visual studio C++ programs I keep facing this screen and having to click through unfortunately.  As a developer I just want my programs to launch straight away each iteration cycle with non of this as it's wasted time - that ironically makes me spend more time then I would like in VR.  Also the amount of RAM that Oculus home uses is unacceptable.  So I think they have some way to go before the current releases development process is smooth IMHO

thewhiteambit
Level 5
once there was registry entry for that, don't know if it is still working

husakm
Level 4
I agree to pass this warning is totally annoying !!! If not registry hack there should be an application interface to control this . The developer should be responsible for his work, not the HW manufacturer ...

Sharkku
Level 3
Yeah, I facepalmed when I saw that message again. I think it is nothing short of idiotic. The way the legal system in the US works... Please, if someone finds a way to remove it, let me know!
DK1 - previously owned DK2 - 2014-08-26 RECEIVED (ordered 2014-04-24) CV1 - 2016-05-25 RECEIVED (ordered on release day) Touch - 2016-12-07 RECEIVED (pre-order with CV1)

jherico
Level 5
On the plus side, for the CV1 hardware with the sensor detecting it's being worn... the message only seems to appear after the headset has not been worn for a certain amount of time.  So at least for a development cycle this is a little less irritating.
Brad Davis - Developer for High Fidelity Co-author of Oculus Rift in Action

whitehexagon
Level 2
+1 for the option to disable HSW again please, back doing dev on my DK2 and it's a PITA especially without an xbox controller to dismiss it.  It means I have to keep putting the HMD on to 'eye click' it.
DK2, MBP (mid 2010) OSX 10.10.3. Win7 - i5 4670K - GTX770. Java LWJGL 3 OpenGL Experiments: https://github.com/WhiteHexagon

kontisleap
Level 2
+1 for such an option, and not only that but also having to keep the Oculus home open at all times to actually debug in UE4 or Unity is a total waste of energy and could lead the screens to some serious burn-in.