Showing results for 
Search instead for 
Did you mean: 

Issues hitting framerate requirement with nothing in a scene

Level 2
I have been having issues with getting my game up to the required 90fps. I am running everything on my Rift S. When I run in the editor with the stats displayed on the game screen it shows it's averaging around 85fps. When I build the application and run the validate app tool it shows my framerate fails every time but it's showing it stuck at 67.7fps. No matter what I change in the game it's always 67.7. Out of frustration I tried loading up a blank project and importing the Oculus Integration package and building and checking with the validate app tool and I still get the same 67.7fps.

When I run the app with the profiler enabled I have a massive processing time on the GPU under the "Other" category taking up about 12ms on it's own which if I understand the math right already brings the app down to 83fps from just that alone. 

I've tried searching around to figure out what could be causing this, but I'm not getting anywhere. The only thing I was able to find was people saying to disable the vSync, which isn't possible in a VR app. 

Any help here would really be appreciated.


Edit: I meant to post this to the Unity Development category. Can this be moved or should I repost over there? I am developing using Unity 2019.1.3

Level 2
Just wanted to follow up on this. I've been working on this problem for the past few days trying different things. I believe that I have resolved this by using an older version of Unity. Originally I was using Unity 2019.1 as indicated in my original post. I installed an older version and tried using Unity 2018.2 and now my frame rate comes in at a perfect 90 fps. I haven't gotten my game completely rebuilt in it yet, but it is working at 90 fps with just the basic Oculus Integration package installed which is a huge improvement.

Level 2
I'm on unity 2019.2 and get weird framerate issues with nearly empty scenes also. I tried turning off vsync and I get near perfect performance, even in my test scenes with two million+ polygons. with vsync, i get that same 67.7 fps, and with vsync off i hit my 80 fps target. What's strange is simple motion (like a cube moving at a fixed or deltatime rate) looks perfectly smooth with vsync off, but with it on at 60fps+ it looks awful, it looks like blurry stop motion, an effect i wouldn't assume would be visibile at a poor but still high framerate.

You mention that turning off vSync isn't "possible" in a VR app. I understand conceptually that it would generate lots of skips when you're rendering at one rate and displaying at another. I haven't been able to find out WHY it's a bad idea to disable vsync, if the result is actually perceptively perfect performance?

Level 2
I couldn't get vsync to turn off. I tried everything I could find on the internet to get vsync to turn off and stay off in the game but I never got it to turn off. I'm curious how you disabled it.