Showing results for 
Search instead for 
Did you mean: 

Oculus app not working / black window / rendering?

Level 4

Hi guys,

I was trying to install the PC App today. The installation worked quite fine. The moment when the VR says to establish the link in the VR and the rest have to be done on the Computer, my Oculus App starts.

This is how it looks like:

I've updated the NVidia graphics driver and repaired the Oculus app. What else can I do? My firewall is off and there is no Virus Defender installed, the active Virus control from Windows is off.


EDIT: Reddit Thread with official oculus support statement:

EDIT2: Use Oculus Tray Tool to restart or kill the service, works fine for me, while troubleshooting back and forth.
Download Link here:

EDIT 3: I have added another mirror for Support.rar, Oculus Tray Tool and USB Deview:

155 REPLIES 155

Ive tried this and just about everything else it just keeps saying i dont have permission to extract into the oculus folder

Have you tried extracting it to a separate or new folder, deleting the old support files, then dragging and dropping the new files into support?

You need to kill all the oculus services before - either use Task Manager or even better the Oculus Tray Tool. As you can see in my vid on youtube:

Level 3

Ah ha! I had a support ticket update from Oculus this morning saying they'd implemented a patch and to please try again. And it worked! I just loaded the setup as before, selected profile picture, confirmed profile picture, and then instead of a grey screen as before it instead loaded a Confirm Privacy Settings page. The step after that let me select my headset and test USB connection then it was done. Sorted!

Level 2

It says its out dated now