cancel
Showing results for 
Search instead for 
Did you mean: 

Quest MRC Final set up

Lazius001
Level 3
Hi,

Hitting a big wall with OBS, need help to finish set up:

Hardware 
Elgato HD60S + Hero6 Gopro;
RTX2070 Nvidia + i7-9700K
Windows 10;

Steps taken:
1. Created a developer account with an organisation name as "y" and App name as "z";
2.Downloaded the Mixed reality resources 2.0 from https://developer.oculus.com/downloads/package/mixed-reality-capture-tools/
3.Set up ADB and device was found;
4.Ran MrcCameraCalibration.apk and able to find the app from the unknown in the Quest deviceo as per link https://developer.oculus.com/documentation/quest/latest/concepts/mr-camera/
5. From the same link as step 4, "Calibrate the Camera", I created an empty mrc.xml file to my desktop, saved the file by clicking "open" as there was no "save" button (even though as admin I had all access - I verified the file after and the camera input were in the file, so the file was not empty after clicking open - then put the file in a location in my C drive;
 ---> I tried to save two files at this step (which I then tested to use in step 7), first file saved the mrc.xml without cliking on "chroma", which is the final step of the "calibrate camera" sequence; then I tried by proceeding to "chroma" sequence and saved that file to camera as a mrc.xml;
-----> I then closed at both times the window to the camera;
----------> trying two methods, I then did as per the instructions in the "Transfer the Calibration File to your Oculus Quest" I as adb shell mkdir -p /sdcard/Android/data/com.{yourorgname}.{yourappname}/files as adb shell mkdir -p /sdcard/Android/data/com.y.z/files, but this also didn't work, so I tried putting adb shell mkdir -p /sdcard/Android/data/com.myoculusaccountname.beatsaber/files (this also in latter steps didn't work);
-----> file was moved successfully, and then went back to home in the vr headset (all this time never did it ask for a guardian recalibration, nor did I make the headset go to sleep as it had tape on it;
6. installed OBS, put all the plugins into the relevant folders as per this link C:\Program Files\Oculus\Oculus Mixed Reality\1.41.0_RC1\OVRCameraCalibration_PC\Assets\mrc.xml;
7. I could see "OculusMrcSource" as the name listed after clicking on the "+" in the source section, it did not say "Oculus MRC" as described;
---> I followed the instructions, but when I tried to apply the "filter crop/pad" my two OculusMrcSource, just either kept being Blue, or Grey;
------> The video capture I used was visible in the OBS, and applied the Chroma in the OBS;
8. I tried to connect the OculusMrcSource, but could not connect....nothing happened...

I tried so many variations to get this to work, but really need help to get this going, would really appreciate your help.

Thanks very much.
Laz
1 REPLY 1

Lazius001
Level 3
Jut update to mention all is set up. Must use previous version of obs for correct mrc camera to work, and use corresponding name of user and their app to be able to connect, only will connect if they updated their app with the quest mrc things.