cancel
Showing results for 
Search instead for 
Did you mean: 

4K video rendering issues on Oculus GO Internet browser using WebVR

Byond_VR
Level 2
Hi everybody,

On a brand new Oculus GO, we are experiencing issues when trying to display a 4K MP4 video as an equitangular sphere.
Debugging it exposes a console error message while trying to load and play it: "Failed to load because no supported source was found."

Important to note that when using the same code exactly in order to play a 2K video, it plays well and as expected.

Is there a known Oculus GO limitation on presenting 4K videos?

Thanks in advance,
Asaf
4 REPLIES 4

Byond_VR
Level 2
Hi @imperativity,
Thank you very much for your response!
I am quite unfamiliar with video transcoding (codecs etc..) settings. So please bare with me 🙂

Here are the video settings (as reflected via VLC):
Codec: h264 - MPEG-4 AVC (part 10) (avc1)
Resolution: 4096x2048
Frame rate: 25
Decoded format: Planar 4:2:0 YUV

Are those settings operable for Oculus GO?

Thanks in advance

Byond_VR
Level 2
Hi @imperativity,
The same problem persists :neutral:
Is there anywhere we can find guide lines or specifications for displaying 4K 360 videos in an Oculus Internet Browser or Oculus GO?
Thanks in advance

benblub2
Level 2
Hi @imperativity

I got a nearly same Problem, please check this File -> http://flux.interpunkt-test.ch/3d.mp4

I setup Unity with skybox panoshader + Player.
Works with 4K mono (3840 x 1920) without problems on OculusGo. If i replace the Video with 4K Stereo (link), then black Screen. (On Vive works)

Video Settings
cmbny6lb0ple.png

benblub2
Level 2
OK i solved it...

Problem was the Size.. of the Video.
https://developer.oculus.com/documentation/mobilesdk/latest/concepts/mobile-media-overview/#mobile-m...
Here are the Limits for the OculusGo

I tested yesterday with decrasing from 3840 x 3840 to 2560x2560 and Videos shows on OculusGo. Has to find out why 3840x3840 not worked if you looked @ my picture frames on 29.7
For stereoscopic videos, the GALAXY S7, S8, and Oculus Go decoders allow for 2560x2560 at 60 FPS and 3840x3840 at 30 FPS.