cancel
Showing results for 
Search instead for 
Did you mean: 

After LaunchCheckoutFlow, stuck on loading (3 dots animation) Unity Quest build (Rift works fine)

futoumei
Level 2
Hi,

In my quest build, when I try to initiate a purchase, it unfocuses my game as expected, but then it's just stuck in the loading animation (those 3 dots), and the purchase dialog never appears.  You can press the menu button and use the menu to resume the game, but this doesn't seem to actually cancel the purchase since the 'OnComplete' never actually fires.   The issue isn't happening in my Rift builds which have the same IAP items uploaded. 

Any insight would be appreciated! Thanks

(Update)
I tried re-uploading the SKU tsvs, and that didn't seem to have any effect.
I also looked the logcat and there don't appear to be any clear errors when the purchase is launched:
06-17 15:46:52.781  1054  1583 I ActivityManager: START u0 {act=launch_checkout_flow cat=[android.intent.category.LAUNCHER] dat=apk://com.oculus.vrshell.home flg=0x10010000 pkg=com.oculus.vrshell cmp=com.oculus.vrshell/.MainActivity (has extras)} from uid 10066 on display 0
... (some unrelated print statements omitted here) ...
06-17 15:46:52.808  7031  7048 I Unity   : [OVRManager] OnApplicationFocus(false)
06-17 15:46:52.808  7031  7048 I Unity   :
06-17 15:46:52.808  7031  7048 I Unity   : (Filename: ./Runtime/Export/Debug.bindings.h Line: 45)
06-17 15:46:52.808  7031  7048 I Unity   :
06-17 15:46:52.825  7031  7048 I Unity   : [OVRManager] OnApplicationPause(true)
06-17 15:46:52.825  7031  7048 I Unity   :
06-17 15:46:52.825  7031  7048 I Unity   : (Filename: ./Runtime/Export/Debug.bindings.h Line: 45)
06-17 15:46:52.825  7031  7048 I Unity   :
06-17 15:46:53.238  1054  1494 I ActivityManager: Start proc 7171:com.oculus.vrshell.home:iap/u0a58 for service com.oculus.vrshell.home/.IAPService


1 REPLY 1

futoumei
Level 2
It turns out that some of my SKUs contained slashes '/', which was messing up the URL which was being generated.  I'm told that that this will be fixed in the future, but if anyone else has this issue, see if your SKU contains characters not valid for URL.