cancel
Showing results for 
Search instead for 
Did you mean: 

ADB device list empty

BBigG
Level 3
Hey there,
when I came back to work this morning, I found both of my
Quests unable to be listed under adb devices. I tried Mac and Win but
the list won't get populated.
In difference to yesterday I realised
that every time I connect a Quest to a computer the Quest will ask to
confirm: "Allow Access to Data. The connected device will be able to
access files on this headset." This wasn't there before remains come
back every time.

I am unable to side load any builds which is kind of a show stopper.

35 REPLIES 35

vrinter
Level 3

TamToucan said:

Like so many I can't get the drivers to work after the latest update. Windows 8.1 and when I plug in my Quest device manager only shows 'Other Devices - XRSP interace' and 'Portable Devices - MTP' there is no ADB Interface.

If I turn off developer mode and connect then the Quest prompts to allow access and again all I see is XRSP and MTP. The XRSP has no driver installed. If I try and update the driver and point it at the latest Quest ADB driver it says it could not find the driver for the device.

Basically no matter what I try I can't get an 'ADB Interface' to appear in device manager to try and manually select the driver.

Any tips? Thanks.


For me it was enough to see the XRSP Interface. Then I would install a driver from my own machine by right-clicking XRSP Interface and choose to update driver. Then "browse my computer for driver software" and "let me pick from a list of device drivers on my computer", and pick "Oculus Bootloader Interface" from the "Oculus devices" category. This only works when XRSP has no driver installed and isn't already part of the USB controllers or USB devices etc in the device manager. Otherwise you can only select from a small amount of drivers.

I didn't need to install any new ADB drivers then. And I left it at that. I've had 4 Oculus Quest devices in the meantime and they all have the same problem that gets temporarily fixed by this.

Then suddenly the one I'm using will stop working after unplugging it for some reason (charging, customer request etc) and at some point hours or a day later (either unplugging, plugging, rebooting etc) work again.



A new problem I have is that Windows 10 won't see the Oculus Quest at all. No beep, no pop-up, no asking for permission in the quest, no unknown or known devices in the device manager. This leaves me with rebooting everything multiple times, changing cables, and switching normal and developer mode multiple times etc till it shows mercy and pops up for no reason.

This is super disruptive to working with the Quest, where is an official statement regarding this problem? Is Oculus not looking at the developer forum at all?

TamToucan
Level 3
Thanks. I'll try that tonight and hopefully get it working. One thing I will say regarding the problem is my previous work was with a fairly well known fitness watch (now discontinued) and I used to help people on the forums with their watch suddenly not being detected by windows. The watch didn't even use a special driver, it was literally the generic driver used for keyboards and mice. Once Windows had decided it didn't recognize the watch the only way I found to recover was I wrote a program to remove all device registry entries for our company. That way it was like plugging the watch in for the first time again.

We never found out just what was actually going on, so to be fair to Oculus I don't think it's entirely their problem, though they could probably come up with a solution to recover once it does break.

vrinter
Level 3
One additional case that I've had multiple times (but inconsistent) is that I install the XRSP driver in normal mode on the Quest. Then I change to developer mode and the Quest disappears from Windows Explorer. I start up Unreal Engine 4, which checks for Android devices to run stuff on. Then the Quest pops up in the Windows Explorer and is accessible for file transfer and deploying.

eleister
Level 3
 @NinjaGaijin Can someone please help with this?  I have read through all of these posts, tried uninstalling and reinstalling updating drivers, turning developer mode on/off, etc. etc. and my Quest will not build from Unity 2019 1.5.  Everything worked perfectly for months and now after this firmware update - nothing.  I have lost so much time!  Please direct me to a solution!

My Quest shows as connected to Unity in the build window.  Shows in my devices as "quest" and when I start the build, changes to MTP.  I've gone into device control and tried to update according to instructions posted by others above, but my machine does not have the same options. Running Windows 10 and my app is running off of an iPhone. 

substatica
Level 3
Very frustrating. On Windows 8.1, I was able to install the Oculus Bootloader driver showing up under Samsung Android Device with Developer Mode off, then after enabling Developer Mode I was able to install the Oculus ADB device -- but now the XRSP Interface shows under USB Devices and the only driver I can set is WinUsb, it won't allow any other device selection and finds nothing compatible in the INF.

IdoWhy
Level 2
I know I'm a bit late but this is literally annoying. Basically, I have everything here but the adb interface doesn't have the option to choose oculus drivers when i press update.